<!doctype html><!--[if IE 8]> <html class="ie ie8" lang="en"> <![endif]--><!--[if gte IE 9]> <html class="no-js ie" lang="en"> <![endif]--><!--[if !IE]><!--> <html class="no-js" lang="en"> <!--<![endif]--><head><style scoped>@import "//fonts.googleapis.com/css?family=Droid+Sans:400,700|Noto+Serif:400,400i,700,700i"</style><title>WWE 2K promises a &#039;special announcement&#039; at Wrestlemania this weekend - VideoGamer.com</title><link href="/static/css/style.v1.css" rel="stylesheet"><link href="//vjs.zencdn.net/5.8/video-js.min.css" rel="stylesheet"><meta name="description" content="Could a WWE 2K22 reveal be imminent?"><meta charset="UTF-8"/><meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1"><meta http-equiv="X-UA-Compatible" content="IE=Edge"><link rel="canonical" href="https://www.videogamer.com/news/wwe-2k-promises-a-special-announcement-at-wrestlemania-this-weekend"><link rel="amphtml" href="https://www.videogamer.com/amp/news/wwe-2k-promises-a-special-announcement-at-wrestlemania-this-weekend"><meta property="fb:app_id" content="121956104551901"><meta property="og:site_name" content="VideoGamer.com"><meta property="og:type" content="article"><meta property="og:title" content="WWE 2K promises a &#039;special announcement&#039; at Wrestlemania this weekend - VideoGamer.com"><meta property="og:description" content="Could a WWE 2K22 reveal be imminent?"><meta property="og:locale" content="en_GB"><meta property="og:url" content="https://www.videogamer.com/news/wwe-2k-promises-a-special-announcement-at-wrestlemania-this-weekend"><meta property="og:image" content="https://s.videogamer.com/images/50ba/be860a0b-5371-4126-ad61-db5db976da90_ss_8d5da064e693c15c4c4750c07e39ca680b77261f.1920x1080.jpg"><link rel="apple-touch-icon" href="https://www.videogamer.com/static/images/apple-touch-icon.png" /><link rel="apple-touch-icon" sizes="72x72" href="https://www.videogamer.com/static/images/apple-touch-icon-72x72.png" /><link rel="apple-touch-icon" sizes="114x114" href="https://www.videogamer.com/static/images/apple-touch-icon-114x114.png" /><link rel="apple-touch-icon" sizes="144x144" href="https://www.videogamer.com/static/images/apple-touch-icon-144x144.png" /><meta name="twitter:card" content="summary" /><meta name="twitter:site" content="VideoGamerCom" /><meta name="twitter:title" content="WWE 2K promises a &#039;special announcement&#039; at Wrestlemania this weekend - VideoGamer.com" /><meta name="twitter:description" content="Could a WWE 2K22 reveal be imminent?" /><meta name="twitter:image" content="https://s.videogamer.com/images/50ba/be860a0b-5371-4126-ad61-db5db976da90_ss_8d5da064e693c15c4c4750c07e39ca680b77261f.1920x1080.jpg" /><link rel="shortcut icon" href="/static/images/favicon.ico"><link rel="icon" sizes="16x16 32x32 64x64" href="/static/images/favicon.ico"><link href="https://www.videogamer.com/rss/allupdates.xml" rel="alternate" type="application/rss+xml" title="VideoGamer.com - All Updates"></head><body class="l-maxwidth l-2column-sidebar js-sidebar-affix fixed-header" data-page-group="article"><div id="fb-root"></div><script src="/static/js/jquery-3.2.1.min.js"></script><script async src="https://www.googletagmanager.com/gtag/js?id=UA-3137559-1"></script><script>window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}gtag('js', new Date());gtag('config', 'UA-3137559-1',{ 'anonymize_ip': true });</script><header id="header" class="header header--border" role="banner"><div class="header__top u-clearfix" role="navigation"><div class="header__container"><nav><a href="/" title="VideoGamer.com" class="header-logo visible-md"><h1>VideoGamer.com</h1></a><div class="header-user-menu nav visible-md"><a class="header-user-menu__login" href="#" title="Login coming shortly."><span class="user-avatar user-avatar--placeholder"><svg role="presentation" class="icon icon-user" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-user"></use></svg></span></a><div class="header-user-menu__login-dd"><div class="temp"><h4>Registration and login are coming shortly.</h4><p>They're not quite ready yet. If you had an account with the old site, don't worry - it will be transferred over.</p></div></div></div><div class="header-navigation"><div class="header-navigation__search"><input type="text" id="gameSearch" title="Search" placeholder="Search"><button class="webicons search"><svg role="presentation" class="icon icon-search" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-search"></use></svg></button><ul class="search-dropdown plain-list scrollable" id="gameSearchList"></ul></div><ul class="nav"><li><a href="/news" title="News">News</a></li><li><a href="/videos" title="Videos">Videos</a></li><li><a href="/reviews" title="Reviews">Reviews</a></li><li class="visible-lg"><a href="/features" title="Features">Features</a></li><li class="invisible-md"><a href="/features" title="Features">Features</a></li><li><a href="/guides" title="Guides">Guides</a></li><li><a href="/podcasts" title="Podcast">Podcast</a></li><li class="invisible-md"><a href="/top-games" title="Top Games">Top Games</a></li><li><a href="/games" title="Games">Games</a></li><li><a href="/forums/" title="Forums">Forums</a></li><li class="visible-lg subscribe"><a href="https://www.patreon.com/VideoGamer" title="Patreon" rel="nofollow">Patreon</a></li><li class="invisible-md subscribe"><a href="https://www.patreon.com/VideoGamer" title="Patreon" rel="nofollow">Patreon</a></li></ul><ul class="nav invisible-md"><li><a href="/staff">Staff</a></li><li><a href="/contact-us">Contact Us</a></li><li><a href="/legal">Legal Info</a></li></ul><ul class="header-navigation__social nav invisible-md"><li><a href="http://www.youtube.com/videogamertv?sub_confirmation=1" class="square-icon social-icon--youtube"><svg role="presentation" class="icon icon-youtube2" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-youtube2"></use></svg></a></li><li><a href="https://twitter.com/intent/user?screen_name=VideoGamerCom" class="square-icon social-icon--twitter"><svg role="presentation" class="icon icon-twitter" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-twitter"></use></svg></a></li><li><a href="http://www.facebook.com/VideoGamerCom" class="square-icon social-icon--facebook"><svg role="presentation" class="icon icon-facebook" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-facebook"></use></svg></a></li><li><a href="/rss" class="square-icon social-icon--rss"><svg role="presentation" class="icon icon-rss" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-rss"></use></svg></a></li></ul></div></nav></div></div></header><div class="header-user-menu__user-dd--responsive"></div><div class="page-skin body_constrain"><div class="header--responsive invisible-md u-clearfix"><a href="/" title="VideoGamer.com" class="header-logo"><h1>VideoGamer.com</h1></a><div class="header--responsive__menu"><svg role="presentation" class="icon icon-bars" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-bars"></use></svg></div><div class="header-user-menu--responsive nav"><a class="header-user-menu__login--responsive" href="/login" title="Log In"><span class="avatar-placeholder"><svg role="presentation" class="icon icon-user" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-user"></use></svg></span></a></div></div>


<div align="center" style="margin-top:10px;"><div id="vnt-lb"></div><script>
    window.top.__vm_add = window.top.__vm_add || [];
    (function(success) { if(window.document.readyState !== "loading") { success(); }
    else { window.document.addEventListener("DOMContentLoaded", function() { success(); } ); }
    } )(function() {
        var placement = document.createElement("div");
        placement.setAttribute("class", "vm-placement");
        if(window.innerWidth > 1000) {
        placement.setAttribute("data-id", "58d923eb46e0fb0001b87563");
        placement.setAttribute("data-display-type", "hybrid-banner");
        } else {
        placement.setAttribute("data-id", "5ae1e94c46e0fb0001aa70a7");
        }
        document.querySelector("#vnt-lb").appendChild(placement);
        window.top.__vm_add.push(placement);
    });
    </script></div><div class="container u-clearfix article-base-page"><main class="main"><article class="article"><div class="article__social js-article-affix"><a href="https://twitter.com/intent/tweet?text=WWE%202K%20promises%20a%20&#039;special%20announcement&#039;%20at%20Wrestlemania%20this%20weekend&amp;url=https%3A%2F%2Fwww.videogamer.com%2Fnews%2Fwwe-2k-promises-a-special-announcement-at-wrestlemania-this-weekend" target="_blank" rel="nofollow" class="rounded-icon social-icon--twitter js-share-twitter"><svg role="presentation" class="icon icon-twitter" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-twitter"></use></svg></a><a href="https://www.facebook.com/dialog/share?app_id=121956104551901&amp;display=page&amp;href=https%3A%2F%2Fwww.videogamer.com%2Fnews%2Fwwe-2k-promises-a-special-announcement-at-wrestlemania-this-weekend" target="_blank" rel="nofollow" class="rounded-icon social-icon--facebook js-share-facebook"><svg role="presentation" class="icon icon-facebook" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-facebook"></use></svg></a></div><div class="article__section--gutter"><div class="article-head"><div class="user-avatar"><img src="/static/images/staff/202.jpg" alt="Ben Borthwick" /></div><div class="article-head__details"><p class="article-head__details__author article-meta">By <span><strong><span>Ben Borthwick</span></strong></span><span class="visible-inline-sm"> &nbsp;&bull;&nbsp; </span><span class="publish-date" title="2021-04-09 10:36:30">09 Apr 2021</span><span class="visible-inline-sm"> &nbsp;&bull;&nbsp; Posted in&nbsp;<a href="/news">News</a><span class="visible-inline-sm"> &nbsp;&bull;&nbsp; </span><span class="visible-inline-sm">Tagged in:&nbsp;<a href="/tag/wwe-2k">WWE 2K</a>, <a href="/tag/2k-games">2K Games</a>, <a href="/tag/news">news</a><br></span></p><h1 class="article-head__details__headline editable255 tooltips article-headline" data-placeholder="Headline" data-name="headline">WWE 2K promises a &#039;special announcement&#039; at Wrestlemania this weekend</h1></div><h2 class="article-head__subheadline editable255" data-placeholder="Subtitle" data-name="subtitle">Could a WWE 2K22 reveal be imminent?</h2></div></div><div class="article__section article__section--full article__section--leader select-embed-lead"><div class="oembed-image"><picture><source srcset="https://thumbs.videogamer.com/BuTfmJ3YIT1SDMM1dz9F92hl7Ps=/960x540/smart/filters:format(webp)/https://s.videogamer.com/images/50ba/be860a0b-5371-4126-ad61-db5db976da90_ss_8d5da064e693c15c4c4750c07e39ca680b77261f.1920x1080.jpg 960w, https://thumbs.videogamer.com/0qJyWWA_W69GefiPTqMZoY_7UDQ=/640x360/smart/filters:format(webp)/https://s.videogamer.com/images/50ba/be860a0b-5371-4126-ad61-db5db976da90_ss_8d5da064e693c15c4c4750c07e39ca680b77261f.1920x1080.jpg 640w, https://thumbs.videogamer.com/IA7bBncV4tKaDthecOJdSjg7Afo=/320x180/smart/filters:format(webp)/https://s.videogamer.com/images/50ba/be860a0b-5371-4126-ad61-db5db976da90_ss_8d5da064e693c15c4c4750c07e39ca680b77261f.1920x1080.jpg 320w, https://thumbs.videogamer.com/snN6asZBHLqbaPVOHanfD-Jy7cI=/120x68/smart/filters:format(webp)/https://s.videogamer.com/images/50ba/be860a0b-5371-4126-ad61-db5db976da90_ss_8d5da064e693c15c4c4750c07e39ca680b77261f.1920x1080.jpg 120w" sizes="(min-width: 768px) 33.3vw, 100vw" type="images/webp"><img class="responsive-image" srcset="https://thumbs.videogamer.com/l25Swkw7_VDZRen25i7g_-5iiX0=/960x540/smart/https://s.videogamer.com/images/50ba/be860a0b-5371-4126-ad61-db5db976da90_ss_8d5da064e693c15c4c4750c07e39ca680b77261f.1920x1080.jpg 960w, https://thumbs.videogamer.com/cfRDQRJKamiOE3HuMRRH7MPg0pQ=/640x360/smart/https://s.videogamer.com/images/50ba/be860a0b-5371-4126-ad61-db5db976da90_ss_8d5da064e693c15c4c4750c07e39ca680b77261f.1920x1080.jpg 640w, https://thumbs.videogamer.com/5nr5u_dz3cpkZS5_aV95HSM_Wio=/320x180/smart/https://s.videogamer.com/images/50ba/be860a0b-5371-4126-ad61-db5db976da90_ss_8d5da064e693c15c4c4750c07e39ca680b77261f.1920x1080.jpg 320w, https://thumbs.videogamer.com/hys1WG_FQfQUSuBmdVpU7WyjU60=/120x68/smart/https://s.videogamer.com/images/50ba/be860a0b-5371-4126-ad61-db5db976da90_ss_8d5da064e693c15c4c4750c07e39ca680b77261f.1920x1080.jpg 120w" src="https://thumbs.videogamer.com/LWVzsxwfmu56q2xxVZ7TNfgLnaI=/320x180/smart/filters:no_upscale()/https://s.videogamer.com/images/50ba/be860a0b-5371-4126-ad61-db5db976da90_ss_8d5da064e693c15c4c4750c07e39ca680b77261f.1920x1080.jpg" alt="WWE 2K promises a &amp;#039;special announcement&amp;#039; at Wrestlemania this weekend" sizes="(min-width: 768px) 33.3vw, 100vw"></picture></div></div><div class="article-body"><div class="article-mpu invisible-md"><div align="center"><div id="vnt-mpub"></div><script>
    window.top.__vm_add = window.top.__vm_add || [];
    (function(success) { if(window.document.readyState !== "loading") { success(); }
    else { window.document.addEventListener("DOMContentLoaded", function() { success(); } ); }
    } )(function() {
        var placement = document.createElement("div");
        placement.setAttribute("class", "vm-placement");
        if(window.innerWidth > 1000) {
        placement.setAttribute("data-id", "58d9240346e0fb0001b8756e");
        } else {
        placement.setAttribute("data-id", "5ae1e92446e0fb0001b614af ");
        }
        document.querySelector("#vnt-mpub").appendChild(placement);
        window.top.__vm_add.push(placement);
    });
    </script></div></div><section>
<div class="article__section article__section--gutter">
<p>The official WWE 2K Games Twitter account has told fans it should tune in to Wrestlemania this weekend for a &#39;special announcement&#39; related to the wrestling simulation series.</p>

<p>There&#39;s no word yet on precisely what the announcement will consist of, but it&#39;s widely expected to be the reveal of this year&#39;s game in the form of <em>WWE 2K22</em>.&nbsp;The main series&nbsp;<a href="https://www.videogamer.com/news/wwe-2k21-is-not-happening-states-wwe" target="_blank">took a year off in 2020 </a>following a poor critical&nbsp;reception to the notoriously buggy release of <em>WWE 2K20</em>, the first entry in the series following <a href="https://www.videogamer.com/news/wwe-2k-series-partners-2k-games-and-yukes-have-separated-" target="_blank">the departure of long-time development studio Yukes</a>.&nbsp;Instead, we got the <a href="https://www.videogamer.com/news/wwe-2k-battlegrounds-comes-to-pc-and-consoles-in-september" target="_blank">more arcade-like <em>WWE 2K Battlegrounds</em>.</a></p>

<p>It was reported <a href="https://www.videogamer.com/news/wwe-2k22-to-rely-on-a-new-philosophical-foundation-to-improve-the-wwe-experience" target="_blank">in June of last year that <em>WWE 2K22</em> will rely on a &quot;new philosophical foundation&quot;</a> in order to avoid the mistakes of the the past, and cites classic wrestling titles <em>WWF No Mercy</em> and <em>WWF Smackdown: Here Comes the Pain</em> as inspirations. Wrestlemania takes place over both Saturday April 10 and Sunday April 11 on the WWE Network in the UK and on the Peacock service in the US and we&#39;ll likely wrestle any relevant videogame scoops from the event into submission early next week.</p>

<figure class="embed-container rich Twitter">
<div class="twitter-tweet twitter-tweet-rendered" style="display: flex; max-width: 550px; width: 100%; margin-top: 10px; margin-bottom: 10px;"><iframe allowfullscreen="true" allowtransparency="true" data-tweet-id="1380203949433761794" frameborder="0" id="twitter-widget-0" scrolling="no" src="https://platform.twitter.com/embed/Tweet.html?dnt=false&amp;embedId=twitter-widget-0&amp;features=eyJ0ZndfZXhwZXJpbWVudHNfY29va2llX2V4cGlyYXRpb24iOnsiYnVja2V0IjoxMjA5NjAwLCJ2ZXJzaW9uIjpudWxsfSwidGZ3X2hvcml6b25fdHdlZXRfZW1iZWRfOTU1NSI6eyJidWNrZXQiOiJodGUiLCJ2ZXJzaW9uIjpudWxsfX0%3D&amp;frame=false&amp;hideCard=false&amp;hideThread=false&amp;id=1380203949433761794&amp;lang=en&amp;origin=https%3A%2F%2Fwww.videogamer.com%2FadminPagesTestA191%2Farticle-edit.php%3Fpermalink%3Dwwe-2k-promises-a-special-announcement-at--wrestlemania-this-weekend&amp;sessionId=075194bf0793b07dc24c5ca85e7dd2f881216e9d&amp;theme=light&amp;widgetsVersion=1ead0c7%3A1617660954974&amp;width=550px" style="position: static; visibility: visible; width: 550px; height: 489px; display: block; flex-grow: 1;" title="Twitter Tweet"></iframe></div>

<p>&nbsp;</p>

<p>&nbsp;</p>
</figure>
</div>
</section>
<div align="center"><div id="ultimedia_wrapper"></div><script type="text/javascript">var ULTIMEDIA_mdtk = "02461417" ;var ULTIMEDIA_zone= "2";var ULTIMEDIA_target = "ultimedia_wrapper";var ULTIMEDIA_async = false;</script><script type="text/javascript" src="https://www.ultimedia.com/js/common/smart.js"></script></div><div align="center"><a href="/forums/" class="breaker__seeall btn btn-primary" alt="Video Gamer Forums">Carry on the conversation on the VideoGamer forums!</a><style type="text/css">.btn-primary:hover{background-color:black;}</style></div><div align="center"><div id="vnt-mpub"></div><script>
    window.top.__vm_add = window.top.__vm_add || [];
    (function(success) { if(window.document.readyState !== "loading") { success(); }
    else { window.document.addEventListener("DOMContentLoaded", function() { success(); } ); }
    } )(function() {
        var placement = document.createElement("div");
        placement.setAttribute("class", "vm-placement");
        if(window.innerWidth > 1000) {
        placement.setAttribute("data-id", "58d9240346e0fb0001b8756e");
        } else {
        placement.setAttribute("data-id", "5ae1e92446e0fb0001b614af ");
        }
        document.querySelector("#vnt-mpub").appendChild(placement);
        window.top.__vm_add.push(placement);
    });
    </script></div></div><div class="article__footer u-clearfix clearboth"><div class="hr margin-block"></div><div class="u-clearBoth margin-block"><a href="https://twitter.com/intent/tweet?text=WWE%202K%20promises%20a%20&#039;special%20announcement&#039;%20at%20Wrestlemania%20this%20weekend&amp;url=https%3A%2F%2Fwww.videogamer.com%2Fnews%2Fwwe-2k-promises-a-special-announcement-at-wrestlemania-this-weekend" target="_blank" rel="nofollow" class="rounded-icon social-icon--twitter js-share-twitter"><svg role="presentation" class="icon icon-twitter" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-twitter"></use></svg></a><a href="https://www.facebook.com/dialog/share?app_id=121956104551901&amp;display=page&amp;href=https%3A%2F%2Fwww.videogamer.com%2Fnews%2Fwwe-2k-promises-a-special-announcement-at-wrestlemania-this-weekend" target="_blank" rel="nofollow" class="rounded-icon social-icon--facebook js-share-facebook"><svg role="presentation" class="icon icon-facebook" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-facebook"></use></svg></a></div></div></article></main><aside class="sidebar"></aside><div class="sidebar_contents sidebar_contents--foot aside"><div align="center"><div id="vnt-mpua"></div><script>
    window.top.__vm_add = window.top.__vm_add || [];
    (function(success) { if(window.document.readyState !== "loading") { success(); }
    else { window.document.addEventListener("DOMContentLoaded", function() { success(); } ); }
    } )(function() {
        var placement = document.createElement("div");
        placement.setAttribute("class", "vm-placement");
        if(window.innerWidth > 1000) {
        placement.setAttribute("data-id", "58d923fb46e0fb0001b87569");
        } else {
        placement.setAttribute("data-id", "5ae1e92446e0fb0001b614af");
        }
        document.querySelector("#vnt-mpua").appendChild(placement);
        window.top.__vm_add.push(placement);
    });
    </script></div><div class="mentioned-games"><div class="mentioned-games__item mentioned-games__item--single"><h3 itemprop="name"><a href="/games/wwe-2k20">WWE 2K20</a></h3><div class="u-clearBoth"><div class="mentioned-games__item__platforms"><strong>on </strong><span>PC, </span><span>PlayStation 4, </span><span>Xbox One</span></div><div class="mentioned-games__item__body"><a href="/games/wwe-2k20" class="box-link"><picture><source srcset="https://thumbs.videogamer.com/KTpaJXHNUC_PssD1hqqbdxkrqCc=/160x/filters:format(webp)/https://s.videogamer.com/meta/6d5a/4538ee7b-2276-4ad1-a3b5-de3085be4dcc_300.jfif 160w, https://thumbs.videogamer.com/4DWFaGJHdPRCRa-voZJ9ZPoh96M=/120x/filters:format(webp)/https://s.videogamer.com/meta/6d5a/4538ee7b-2276-4ad1-a3b5-de3085be4dcc_300.jfif 120w" sizes="(min-width: 992px) 15vw, 33.3vw" type="images/webp"><img class="responsive-image" srcset="https://thumbs.videogamer.com/UKqdo9_4n7HRVkT-ZsBkkYWFqrA=/160x/https://s.videogamer.com/meta/6d5a/4538ee7b-2276-4ad1-a3b5-de3085be4dcc_300.jfif 160w, https://thumbs.videogamer.com/yhCKzcihbeOKFjN4aFckS1fLGK0=/120x/https://s.videogamer.com/meta/6d5a/4538ee7b-2276-4ad1-a3b5-de3085be4dcc_300.jfif 120w" src="https://thumbs.videogamer.com/FHQ4o3MI_9zSY2AcYDGykH_QM0o=/240x/filters:no_upscale()/https://s.videogamer.com/meta/6d5a/4538ee7b-2276-4ad1-a3b5-de3085be4dcc_300.jfif" alt="WWE 2K20" sizes="(min-width: 992px) 15vw, 33.3vw"></picture></a><span itemprop="description"><em>No description yet...</em></span></div><div class="mentioned-games__item__release"><strong>First Released:</strong> 22 October 2019</div><a href="/games/wwe-2k20" class="btn btn-visit-gamespace"><span class="btn-visit-gamespace__icon">g</span>Visit game space</a><a href="http://www.amazon.co.uk/gp/search?ie=UTF8&amp;camp=1634&amp;tag=prog-21&amp;creative=6738&amp;index=videogames&amp;keywords=WWE 2K20&amp;linkCode=ur2" class="btn-buy-amazon mentioned-games__item__buy" target="_blank" rel="nofollow"><span class="amazon-logo"><svg width="100%" height="100%"><image xlink:href="/static/images/amazon.svg" src="/static/images/amazon.svg" width="100%" height="100%" /></svg></span><span class="check-prices">Check Prices</span></a></div></div><div align="center"><div id="vnt-mpub"></div><script>
    window.top.__vm_add = window.top.__vm_add || [];
    (function(success) { if(window.document.readyState !== "loading") { success(); }
    else { window.document.addEventListener("DOMContentLoaded", function() { success(); } ); }
    } )(function() {
        var placement = document.createElement("div");
        placement.setAttribute("class", "vm-placement");
        if(window.innerWidth > 1000) {
        placement.setAttribute("data-id", "58d9240346e0fb0001b8756e");
        } else {
        placement.setAttribute("data-id", "5ae1e92446e0fb0001b614af ");
        }
        document.querySelector("#vnt-mpub").appendChild(placement);
        window.top.__vm_add.push(placement);
    });
    </script></div><section class="sidebar_item popular-articles"><h2>Popular Now</h2><ul class="content-list content-list--aside"><li class="content-item"><a href="/news/lego-star-wars-the-skywalker-saga-delayed-out-of-spring-2021"><div class="content-item__image"><picture><source srcset="https://thumbs.videogamer.com/9KDd37SDcUHgJPc78WddwNNTHzs=/640x360/smart/filters:format(webp)/https://s.videogamer.com/meta/165e/831d62dd-52cd-40f1-806b-8332c4b0007d_LegoStarWarsSkywalkerSaga.jpg 640w, https://thumbs.videogamer.com/sBKqjP8wbVEvxBcNOugSVNlfiDM=/320x180/smart/filters:format(webp)/https://s.videogamer.com/meta/165e/831d62dd-52cd-40f1-806b-8332c4b0007d_LegoStarWarsSkywalkerSaga.jpg 320w, https://thumbs.videogamer.com/FH01qDZiFJeGZSUyHdEdKpf7Q4w=/120x68/smart/filters:format(webp)/https://s.videogamer.com/meta/165e/831d62dd-52cd-40f1-806b-8332c4b0007d_LegoStarWarsSkywalkerSaga.jpg 120w" sizes="20vw" type="images/webp"><img class="responsive-image" srcset="https://thumbs.videogamer.com/D5xr8H6fx9wQru5sInT5wKWs9c4=/640x360/smart/https://s.videogamer.com/meta/165e/831d62dd-52cd-40f1-806b-8332c4b0007d_LegoStarWarsSkywalkerSaga.jpg 640w, https://thumbs.videogamer.com/Yk-t-CeFknnTHgvTxtE9P2qi6hI=/320x180/smart/https://s.videogamer.com/meta/165e/831d62dd-52cd-40f1-806b-8332c4b0007d_LegoStarWarsSkywalkerSaga.jpg 320w, https://thumbs.videogamer.com/p3PsLSzxzt2Kkl9KvdCEYcmS0hw=/120x68/smart/https://s.videogamer.com/meta/165e/831d62dd-52cd-40f1-806b-8332c4b0007d_LegoStarWarsSkywalkerSaga.jpg 120w" src="https://thumbs.videogamer.com/8Jqv9JtbAHnnO88Sbnfjb4cv3cI=/320x240/smart/filters:no_upscale()/https://s.videogamer.com/meta/165e/831d62dd-52cd-40f1-806b-8332c4b0007d_LegoStarWarsSkywalkerSaga.jpg" alt="Lego Star Wars: The Skywalker Saga delayed out of Spring 2021" sizes="20vw"></picture><span class="content-item__article-type">NEWS</span></div><div class="content-item__details"><h3>Lego Star Wars: The Skywalker Saga delayed out of Spring 2021</h3></div></a></li><li class="content-item"><a href="/news/crysis-remastered-gets-a-new-update-adding-ascension-level-and-next-gen-console-upgrades"><div class="content-item__image"><picture><source srcset="https://thumbs.videogamer.com/elVk5wbuKIdsIon5ILRAkInvIWU=/640x360/smart/filters:format(webp)/https://s.videogamer.com/meta/7e90/e79ca662-059f-40aa-9ea4-962116560532_013aeb92-7c47-40b1-a42f-b761fcb5515b_download_(9).jpg 640w, https://thumbs.videogamer.com/Nw7Rf3ocqnATN54DGzfW96DbfpQ=/320x180/smart/filters:format(webp)/https://s.videogamer.com/meta/7e90/e79ca662-059f-40aa-9ea4-962116560532_013aeb92-7c47-40b1-a42f-b761fcb5515b_download_(9).jpg 320w, https://thumbs.videogamer.com/Wkyj1M9YCraU8f3f8PlCBS5XsPQ=/120x68/smart/filters:format(webp)/https://s.videogamer.com/meta/7e90/e79ca662-059f-40aa-9ea4-962116560532_013aeb92-7c47-40b1-a42f-b761fcb5515b_download_(9).jpg 120w" sizes="20vw" type="images/webp"><img class="responsive-image" srcset="https://thumbs.videogamer.com/24c7SSpYWFpcRkMZtbq4cMJ1rgg=/640x360/smart/https://s.videogamer.com/meta/7e90/e79ca662-059f-40aa-9ea4-962116560532_013aeb92-7c47-40b1-a42f-b761fcb5515b_download_(9).jpg 640w, https://thumbs.videogamer.com/3sSpiaNeX9-8mnqBrhkRL-Hu0Dw=/320x180/smart/https://s.videogamer.com/meta/7e90/e79ca662-059f-40aa-9ea4-962116560532_013aeb92-7c47-40b1-a42f-b761fcb5515b_download_(9).jpg 320w, https://thumbs.videogamer.com/I8JZ2wSaWmjSuVbD76i7QmGXU8o=/120x68/smart/https://s.videogamer.com/meta/7e90/e79ca662-059f-40aa-9ea4-962116560532_013aeb92-7c47-40b1-a42f-b761fcb5515b_download_(9).jpg 120w" src="https://thumbs.videogamer.com/ylcPlLdGz89__HiUbLaqUdkJfRs=/320x240/smart/filters:no_upscale()/https://s.videogamer.com/meta/7e90/e79ca662-059f-40aa-9ea4-962116560532_013aeb92-7c47-40b1-a42f-b761fcb5515b_download_(9).jpg" alt="Crysis Remastered gets a new update adding Ascension level and next-gen console upgrades" sizes="20vw"></picture><span class="content-item__article-type">NEWS</span></div><div class="content-item__details"><h3>Crysis Remastered gets a new update adding Ascension level and next-gen console upgrades</h3></div></a></li><li class="content-item"><a href="/news/turn-10-inviting-players-to-playtest-the-next-forza-motorsport"><div class="content-item__image"><picture><source srcset="https://thumbs.videogamer.com/z-9NE2fphV2Wa8aURX6NC6JaNmI=/640x360/smart/filters:format(webp)/https://s.videogamer.com/meta/336c/8e50dcfd-6967-45f9-a1c8-0a93c035a4e4_0cdbff5d-293b-4bd4-93a6-7774e53768a8_Screenshot_2021-04-07_Forza_Motorsport_-_Official_Announce_Trailer.jpg 640w, https://thumbs.videogamer.com/wn5b4kCC4OrOFEMa5icAk1CnUVQ=/320x180/smart/filters:format(webp)/https://s.videogamer.com/meta/336c/8e50dcfd-6967-45f9-a1c8-0a93c035a4e4_0cdbff5d-293b-4bd4-93a6-7774e53768a8_Screenshot_2021-04-07_Forza_Motorsport_-_Official_Announce_Trailer.jpg 320w, https://thumbs.videogamer.com/NosahWOyNOqt_38fyxsMaGdLxdY=/120x68/smart/filters:format(webp)/https://s.videogamer.com/meta/336c/8e50dcfd-6967-45f9-a1c8-0a93c035a4e4_0cdbff5d-293b-4bd4-93a6-7774e53768a8_Screenshot_2021-04-07_Forza_Motorsport_-_Official_Announce_Trailer.jpg 120w" sizes="20vw" type="images/webp"><img class="responsive-image" srcset="https://thumbs.videogamer.com/2XCURACS3EQKpyRiuwnWulwkoM0=/640x360/smart/https://s.videogamer.com/meta/336c/8e50dcfd-6967-45f9-a1c8-0a93c035a4e4_0cdbff5d-293b-4bd4-93a6-7774e53768a8_Screenshot_2021-04-07_Forza_Motorsport_-_Official_Announce_Trailer.jpg 640w, https://thumbs.videogamer.com/qQSPH7hUcZof7C8AgrriEf2cStI=/320x180/smart/https://s.videogamer.com/meta/336c/8e50dcfd-6967-45f9-a1c8-0a93c035a4e4_0cdbff5d-293b-4bd4-93a6-7774e53768a8_Screenshot_2021-04-07_Forza_Motorsport_-_Official_Announce_Trailer.jpg 320w, https://thumbs.videogamer.com/z3_nVCsWBgjMLYmN4022tLSFqZA=/120x68/smart/https://s.videogamer.com/meta/336c/8e50dcfd-6967-45f9-a1c8-0a93c035a4e4_0cdbff5d-293b-4bd4-93a6-7774e53768a8_Screenshot_2021-04-07_Forza_Motorsport_-_Official_Announce_Trailer.jpg 120w" src="https://thumbs.videogamer.com/314SAOF5IWnrv12CZjmEkX48bNE=/320x240/smart/filters:no_upscale()/https://s.videogamer.com/meta/336c/8e50dcfd-6967-45f9-a1c8-0a93c035a4e4_0cdbff5d-293b-4bd4-93a6-7774e53768a8_Screenshot_2021-04-07_Forza_Motorsport_-_Official_Announce_Trailer.jpg" alt="Turn 10 inviting players to playtest the next Forza Motorsport" sizes="20vw"></picture><span class="content-item__article-type">NEWS</span></div><div class="content-item__details"><h3>Turn 10 inviting players to playtest the next Forza Motorsport</h3></div></a></li><li class="content-item"><a href="/news/naughty-dog-rumoured-to-be-working-on-a-ps5-remake-of-the-last-of-us"><div class="content-item__image"><picture><source srcset="https://thumbs.videogamer.com/RSDo5RjQL8Cr-zM4cfxU2PXgpVs=/640x360/smart/filters:format(webp)/https://s.videogamer.com/images/0515/the_last_of_us_remastered_28.jpg 640w, https://thumbs.videogamer.com/aqpnclaWMHrzHmBV8ezAkITWtaU=/320x180/smart/filters:format(webp)/https://s.videogamer.com/images/0515/the_last_of_us_remastered_28.jpg 320w, https://thumbs.videogamer.com/Pkwx-MWUNckUkjENoJaWARtfcEQ=/120x68/smart/filters:format(webp)/https://s.videogamer.com/images/0515/the_last_of_us_remastered_28.jpg 120w" sizes="20vw" type="images/webp"><img class="responsive-image" srcset="https://thumbs.videogamer.com/S9sJojnUTqllxbFnMlDRbcngZmY=/640x360/smart/https://s.videogamer.com/images/0515/the_last_of_us_remastered_28.jpg 640w, https://thumbs.videogamer.com/U4wWKcnMTb6upZAMm_yVBRO_gJA=/320x180/smart/https://s.videogamer.com/images/0515/the_last_of_us_remastered_28.jpg 320w, https://thumbs.videogamer.com/EPAdBSUSXAwIAFd57-BHyyP9lXM=/120x68/smart/https://s.videogamer.com/images/0515/the_last_of_us_remastered_28.jpg 120w" src="https://thumbs.videogamer.com/3haryDKE1Nz_Lx9UesntUCFAka4=/320x240/smart/filters:no_upscale()/https://s.videogamer.com/images/0515/the_last_of_us_remastered_28.jpg" alt="Naughty Dog rumoured to be working on a PS5 remake of The Last of Us" sizes="20vw"></picture><span class="content-item__article-type">NEWS</span></div><div class="content-item__details"><h3>Naughty Dog rumoured to be working on a PS5 remake of The Last of Us</h3></div></a></li><li class="content-item"><a href="/news/mass-effect-legendary-edition-details-gameplay-calibrations-made-to-me1--more-in-new-blog-update"><div class="content-item__image"><picture><source srcset="https://thumbs.videogamer.com/eE34iw-kH_XGkTULiuwvksNOZgI=/640x360/smart/filters:format(webp)/https://s.videogamer.com/images/5a6e/b2e352c0-3ca9-412d-bcc9-c64db76cee07_mele-screenshot-reveal-clean-01.jpg 640w, https://thumbs.videogamer.com/xePIv76xF3i_kIHGlkOQLRhILjI=/320x180/smart/filters:format(webp)/https://s.videogamer.com/images/5a6e/b2e352c0-3ca9-412d-bcc9-c64db76cee07_mele-screenshot-reveal-clean-01.jpg 320w, https://thumbs.videogamer.com/ZyJmH1m7hskgaRlYGhm8j2WbfyY=/120x68/smart/filters:format(webp)/https://s.videogamer.com/images/5a6e/b2e352c0-3ca9-412d-bcc9-c64db76cee07_mele-screenshot-reveal-clean-01.jpg 120w" sizes="20vw" type="images/webp"><img class="responsive-image" srcset="https://thumbs.videogamer.com/JoZYw8szNrNbrMULgBZVDZFC8UM=/640x360/smart/https://s.videogamer.com/images/5a6e/b2e352c0-3ca9-412d-bcc9-c64db76cee07_mele-screenshot-reveal-clean-01.jpg 640w, https://thumbs.videogamer.com/GXxwiNrjcp1oHZTkL9dVsoHkUJw=/320x180/smart/https://s.videogamer.com/images/5a6e/b2e352c0-3ca9-412d-bcc9-c64db76cee07_mele-screenshot-reveal-clean-01.jpg 320w, https://thumbs.videogamer.com/ImNHQNWW3a0nvfMYFihNrjMHbkY=/120x68/smart/https://s.videogamer.com/images/5a6e/b2e352c0-3ca9-412d-bcc9-c64db76cee07_mele-screenshot-reveal-clean-01.jpg 120w" src="https://thumbs.videogamer.com/JSYeVL2ni5zu1xIeUG7SVf_EBuk=/320x240/smart/filters:no_upscale()/https://s.videogamer.com/images/5a6e/b2e352c0-3ca9-412d-bcc9-c64db76cee07_mele-screenshot-reveal-clean-01.jpg" alt="Mass Effect Legendary Edition details gameplay calibrations made to ME1 &amp; more in new blog update" sizes="20vw"></picture><span class="content-item__article-type">NEWS</span></div><div class="content-item__details"><h3>Mass Effect Legendary Edition details gameplay calibrations made to ME1 & more in new blog update</h3></div></a></li><li class="content-item"><a href="/news/abandoned-is-a-cinematic-survival-fps-heading-exclusively-to-playstation-5-in-2021"><div class="content-item__image"><picture><source srcset="https://thumbs.videogamer.com/2V0HsfozyHqdtr7F5X8AQeHAN0w=/640x360/smart/filters:format(webp)/https://s.videogamer.com/meta/572f/f4e95905-3d67-4565-9557-54470ba9c77b_AbandonedScreen1.jpg 640w, https://thumbs.videogamer.com/gL8fwJGTvT8mDlPE-VmVy2O9o-g=/320x180/smart/filters:format(webp)/https://s.videogamer.com/meta/572f/f4e95905-3d67-4565-9557-54470ba9c77b_AbandonedScreen1.jpg 320w, https://thumbs.videogamer.com/5hDSjpQuUHcm59NUsspWNH5TFXw=/120x68/smart/filters:format(webp)/https://s.videogamer.com/meta/572f/f4e95905-3d67-4565-9557-54470ba9c77b_AbandonedScreen1.jpg 120w" sizes="20vw" type="images/webp"><img class="responsive-image" srcset="https://thumbs.videogamer.com/hF02nWgqmPfq0m2pbStv4vUGim8=/640x360/smart/https://s.videogamer.com/meta/572f/f4e95905-3d67-4565-9557-54470ba9c77b_AbandonedScreen1.jpg 640w, https://thumbs.videogamer.com/xHtWmJJRwTMLg8mzyD7huSey7PI=/320x180/smart/https://s.videogamer.com/meta/572f/f4e95905-3d67-4565-9557-54470ba9c77b_AbandonedScreen1.jpg 320w, https://thumbs.videogamer.com/dZO7nKs3c6OyXYpC8pWnG3z8Efw=/120x68/smart/https://s.videogamer.com/meta/572f/f4e95905-3d67-4565-9557-54470ba9c77b_AbandonedScreen1.jpg 120w" src="https://thumbs.videogamer.com/fycMCwj800_EUzCYWsQtJ8iSoK4=/320x240/smart/filters:no_upscale()/https://s.videogamer.com/meta/572f/f4e95905-3d67-4565-9557-54470ba9c77b_AbandonedScreen1.jpg" alt="Abandoned is a cinematic survival FPS heading exclusively to PlayStation 5 in 2021" sizes="20vw"></picture><span class="content-item__article-type">NEWS</span></div><div class="content-item__details"><h3>Abandoned is a cinematic survival FPS heading exclusively to PlayStation 5 in 2021</h3></div></a></li><li class="content-item"><a href="/news/sea-of-thieves-raises-the-anchor-on-season-two-on-april-15"><div class="content-item__image"><picture><source srcset="https://thumbs.videogamer.com/DF9ibOZKO9IOFPcDPSgOpKv2T5Q=/640x360/smart/filters:format(webp)/https://s.videogamer.com/meta/71d0/f4839c39-7c43-4c07-8d6a-752dddf88be8_SoTSeasonTwo.jpg 640w, https://thumbs.videogamer.com/pM0xg_PAkXacrppjLQgez2axtwI=/320x180/smart/filters:format(webp)/https://s.videogamer.com/meta/71d0/f4839c39-7c43-4c07-8d6a-752dddf88be8_SoTSeasonTwo.jpg 320w, https://thumbs.videogamer.com/K1dPyVvvAsuoRXwoHQb4MTK19v4=/120x68/smart/filters:format(webp)/https://s.videogamer.com/meta/71d0/f4839c39-7c43-4c07-8d6a-752dddf88be8_SoTSeasonTwo.jpg 120w" sizes="20vw" type="images/webp"><img class="responsive-image" srcset="https://thumbs.videogamer.com/E04-IbSySpLYOv9V4N2TyBdPJbc=/640x360/smart/https://s.videogamer.com/meta/71d0/f4839c39-7c43-4c07-8d6a-752dddf88be8_SoTSeasonTwo.jpg 640w, https://thumbs.videogamer.com/ZFvsUzR_OO6v2a96thUHOEoJeTA=/320x180/smart/https://s.videogamer.com/meta/71d0/f4839c39-7c43-4c07-8d6a-752dddf88be8_SoTSeasonTwo.jpg 320w, https://thumbs.videogamer.com/lZ53fq-exo70kJbudcd8wjfuiEw=/120x68/smart/https://s.videogamer.com/meta/71d0/f4839c39-7c43-4c07-8d6a-752dddf88be8_SoTSeasonTwo.jpg 120w" src="https://thumbs.videogamer.com/jh0SV5boeD7ohjXDXnjRBu4t-jM=/320x240/smart/filters:no_upscale()/https://s.videogamer.com/meta/71d0/f4839c39-7c43-4c07-8d6a-752dddf88be8_SoTSeasonTwo.jpg" alt="Sea of Thieves raises the anchor on Season Two on April 15" sizes="20vw"></picture><span class="content-item__article-type">NEWS</span></div><div class="content-item__details"><h3>Sea of Thieves raises the anchor on Season Two on April 15</h3></div></a></li><li class="content-item"><a href="/news/returnal-developers-speak-on-the-games-narrative-in-latest-housecast-video"><div class="content-item__image"><picture><source srcset="https://thumbs.videogamer.com/ucDQfmdU-2-wNtwbKHHPNpHzSpA=/640x360/smart/filters:format(webp)/https://s.videogamer.com/meta/aa7d/11895077-15d7-4579-8d44-bed3d446ac20_ReturnalHouseNarrative.jpg 640w, https://thumbs.videogamer.com/AfCRZ7qCCr-TzALuIXMU-wqATMk=/320x180/smart/filters:format(webp)/https://s.videogamer.com/meta/aa7d/11895077-15d7-4579-8d44-bed3d446ac20_ReturnalHouseNarrative.jpg 320w, https://thumbs.videogamer.com/y0-Drf_uCeE8oxkK-GbaDBVpkvU=/120x68/smart/filters:format(webp)/https://s.videogamer.com/meta/aa7d/11895077-15d7-4579-8d44-bed3d446ac20_ReturnalHouseNarrative.jpg 120w" sizes="20vw" type="images/webp"><img class="responsive-image" srcset="https://thumbs.videogamer.com/c5JHScEnPiyRXRgq9qcUZrFWVSM=/640x360/smart/https://s.videogamer.com/meta/aa7d/11895077-15d7-4579-8d44-bed3d446ac20_ReturnalHouseNarrative.jpg 640w, https://thumbs.videogamer.com/3XX4Gz-n7kfsx0bS7U1QvkAuMYk=/320x180/smart/https://s.videogamer.com/meta/aa7d/11895077-15d7-4579-8d44-bed3d446ac20_ReturnalHouseNarrative.jpg 320w, https://thumbs.videogamer.com/_FcoaofybXroAPOHD4aan4p8BcE=/120x68/smart/https://s.videogamer.com/meta/aa7d/11895077-15d7-4579-8d44-bed3d446ac20_ReturnalHouseNarrative.jpg 120w" src="https://thumbs.videogamer.com/CxlE26bwpbahtBLGl-sGkp0_0fo=/320x240/smart/filters:no_upscale()/https://s.videogamer.com/meta/aa7d/11895077-15d7-4579-8d44-bed3d446ac20_ReturnalHouseNarrative.jpg" alt="Returnal developers speak on the game&amp;#039;s narrative in latest HouseCast video" sizes="20vw"></picture><span class="content-item__article-type">NEWS</span></div><div class="content-item__details"><h3>Returnal developers speak on the game's narrative in latest HouseCast video</h3></div></a></li><li class="content-item"><a href="/news/pac-man-99-announced-and-will-release-exclusively-on-nintendo-switch-tonight"><div class="content-item__image"><picture><source srcset="https://thumbs.videogamer.com/sizOxIMy2UiTlUGWGoMHc-woHQk=/640x360/smart/filters:format(webp)/https://s.videogamer.com/meta/40e8/daad4a68-6133-401d-8dc6-3f330cdeb955_PacMan99Splash.jpg 640w, https://thumbs.videogamer.com/mJfPhQzy8c8xch2bX11I1J8FCjE=/320x180/smart/filters:format(webp)/https://s.videogamer.com/meta/40e8/daad4a68-6133-401d-8dc6-3f330cdeb955_PacMan99Splash.jpg 320w, https://thumbs.videogamer.com/7-zUwgEwnuTo9CVvKuDHNZ1iIjY=/120x68/smart/filters:format(webp)/https://s.videogamer.com/meta/40e8/daad4a68-6133-401d-8dc6-3f330cdeb955_PacMan99Splash.jpg 120w" sizes="20vw" type="images/webp"><img class="responsive-image" srcset="https://thumbs.videogamer.com/QkQSvJoX88xIuHF4EeuwuDJ4Su4=/640x360/smart/https://s.videogamer.com/meta/40e8/daad4a68-6133-401d-8dc6-3f330cdeb955_PacMan99Splash.jpg 640w, https://thumbs.videogamer.com/b3Jq0VbJJygP2AZgBripiMqGk3E=/320x180/smart/https://s.videogamer.com/meta/40e8/daad4a68-6133-401d-8dc6-3f330cdeb955_PacMan99Splash.jpg 320w, https://thumbs.videogamer.com/N8MeHsXJurXfb9GJt7JivXPAof8=/120x68/smart/https://s.videogamer.com/meta/40e8/daad4a68-6133-401d-8dc6-3f330cdeb955_PacMan99Splash.jpg 120w" src="https://thumbs.videogamer.com/zCOeFkJmpbZwjctyFllNeU0HYck=/320x240/smart/filters:no_upscale()/https://s.videogamer.com/meta/40e8/daad4a68-6133-401d-8dc6-3f330cdeb955_PacMan99Splash.jpg" alt="Pac-Man 99 announced and will release exclusively on Nintendo Switch tonight" sizes="20vw"></picture><span class="content-item__article-type">NEWS</span></div><div class="content-item__details"><h3>Pac-Man 99 announced and will release exclusively on Nintendo Switch tonight</h3></div></a></li><li class="content-item"><a href="/news/outriders-developers-say-the-games-first-patch-should-be-expected-next-week"><div class="content-item__image"><picture><source srcset="https://thumbs.videogamer.com/6LbkpJakgNm_ZNNIAqvpA6HN9Q0=/640x360/smart/filters:format(webp)/https://s.videogamer.com/images/5ddd/5e1d43a8-eec1-4bd1-a948-f7f987f16732_Outriders_2020_02-13-20_002.jpg 640w, https://thumbs.videogamer.com/97YeUMt02nEibeb8HrvUUQgXYt8=/320x180/smart/filters:format(webp)/https://s.videogamer.com/images/5ddd/5e1d43a8-eec1-4bd1-a948-f7f987f16732_Outriders_2020_02-13-20_002.jpg 320w, https://thumbs.videogamer.com/pjRiFBRzXgkGjoCzC5DMRzqOIzI=/120x68/smart/filters:format(webp)/https://s.videogamer.com/images/5ddd/5e1d43a8-eec1-4bd1-a948-f7f987f16732_Outriders_2020_02-13-20_002.jpg 120w" sizes="20vw" type="images/webp"><img class="responsive-image" srcset="https://thumbs.videogamer.com/oDT7fKXrATdI1RJ_xBrcF4dOv6o=/640x360/smart/https://s.videogamer.com/images/5ddd/5e1d43a8-eec1-4bd1-a948-f7f987f16732_Outriders_2020_02-13-20_002.jpg 640w, https://thumbs.videogamer.com/MmDhUS_vV5foyj4CficJnUFaQtg=/320x180/smart/https://s.videogamer.com/images/5ddd/5e1d43a8-eec1-4bd1-a948-f7f987f16732_Outriders_2020_02-13-20_002.jpg 320w, https://thumbs.videogamer.com/hJlwmAR4J8Li6wMQdYrCS6pOOt0=/120x68/smart/https://s.videogamer.com/images/5ddd/5e1d43a8-eec1-4bd1-a948-f7f987f16732_Outriders_2020_02-13-20_002.jpg 120w" src="https://thumbs.videogamer.com/_v5ITCe4UPhEPGqU7_-zGnW_VKE=/320x240/smart/filters:no_upscale()/https://s.videogamer.com/images/5ddd/5e1d43a8-eec1-4bd1-a948-f7f987f16732_Outriders_2020_02-13-20_002.jpg" alt="Outriders developers say the game&amp;#039;s first patch should be expected next week" sizes="20vw"></picture><span class="content-item__article-type">NEWS</span></div><div class="content-item__details"><h3>Outriders developers say the game's first patch should be expected next week</h3></div></a></li></ul></section></div><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script><footer class="footer"><a href="https://twitter.com/intent/user?screen_name=VideoGamerCom" class="footer_link" rel="nofollow"><span class="rounded-icon social-icon--twitter"><svg role="presentation" class="icon icon-twitter" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-twitter"></use></svg></span>Follow us</a><a href="https://www.youtube.com/VideoGamerTV?sub_confirmation=1" class="footer_link" rel="nofollow"><span class="rounded-icon social-icon--youtube"><svg role="presentation" class="icon icon-youtube2" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-youtube2"></use></svg></span>Watch us</a><a href="https://www.facebook.com/VideoGamerCom" class="footer_link" rel="nofollow"><span class="rounded-icon social-icon--facebook"><svg role="presentation" class="icon icon-facebook" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-facebook"></use></svg></span>Like us</a><a href="/rss" class="footer_link" rel="nofollow"><span class="rounded-icon social-icon--rss"><svg role="presentation" class="icon icon-rss" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-rss"></use></svg></span>Subscribe</a><ul class="nav"><li><strong>&copy; 2018</strong></li><li><a href="/staff" title="Staff" rel="nofollow">Staff</a></li><li><a href="/contact-us" title="Contact" rel="nofollow">Contact</a></li><li><a href="/legal" title="Legal" rel="nofollow">Legal</a></li><li><a href="/privacy-policy" title="Privacy" rel="nofollow">Privacy Policy</a></li></ul><div class="footer_meta"><a href="http://www.reseronetwork.com" title="Resero Network" class="network_logo"><h4>Resero Network</h4></a><div class="network_sites js-hover"><span>Our Sites</span><ul><li><a href="http://pt.videogamer.com" title="VideoGamer Portugal">VideoGamer Portugal</a></li><li><a href="http://it.videogamer.com" title="VideoGamer Italy">VideoGamer Italy</a></li><li><a href="http://www.videogamer.gr" title="VideoGamer Greece">VideoGamer Greece</a></li><li><a href="https://www.xboxachievements.com" title="VideoGamer Greece">Xbox Achievements</a></li><li><a href="https://www.playstationtrophies.org" title="VideoGamer Greece">PlayStation Trophies</a></li></ul><svg role="presentation" class="icon icon-chevron-up" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-chevron-up"></use></svg></div></div></footer></div></div><div class="pswp" tabindex="-1" role="dialog" aria-hidden="true"><div class="pswp_advert"><div class="advert mpu-second" id="adunit-mpu-second" data-slot=""></div></div><div class="pswp__bg"></div><div class="pswp__scroll-wrap"><div class="pswp__container"><div class="pswp__item"></div><div class="pswp__item"></div><div class="pswp__item"></div></div><div class="pswp__ui pswp__ui--hidden"><div class="pswp__top-bar"><div class="pswp__counter invisible"></div><div class="pswp__customcounter"></div><button class="pswp__button pswp__button--close" title="Close (Esc)"><svg role="presentation" class="icon icon-cross" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-cross"></use></svg></button><button class="pswp__button pswp__button--fs" title="Toggle fullscreen"><svg role="presentation" class="icon icon-expand" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-expand"></use></svg></button><button class="pswp__button pswp__button--zoom" title="Zoom in/out"><svg role="presentation" class="icon icon-search" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-search"></use></svg></button><div class="pswp__preloader"><div class="pswp__preloader__icn"><div class="pswp__preloader__cut"><div class="pswp__preloader__donut"></div></div></div></div></div><div class="pswp__share-modal pswp__share-modal--hidden pswp__single-tap"><div class="pswp__share-tooltip"></div></div><button class="pswp__button pswp__button--arrow--left" title="Previous (arrow left)"><svg role="presentation" class="icon icon-chevron-left" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-chevron-left"></use></svg></button><button class="pswp__button pswp__button--arrow--right" title="Next (arrow right)"><svg role="presentation" class="icon icon-chevron-right" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-chevron-right"></use></svg></button><div class="pswp__caption"><div class="pswp__caption__center"></div></div></div></div></div>
<!-- Venatus Market v3 -->
<script>
    (function() {
        document.write('<div id="vmv3-ad-manager" style="display:none"></div>');
        document
            .getElementById("vmv3-ad-manager")
            .innerHTML = '<iframe id="vmv3-frm" src="javascript:\'<html><body></body></html>\'" width="0" height="0" data-mode="scan" data-site-id="58d923da46e0fb00017904ed"></iframe>';
        var loaderFrame = document.getElementById("vmv3-frm");
        var loaderFrameWindow = loaderFrame.contentWindow ? loaderFrame.contentWindow  : loaderFrame.contentDocument;
        loaderFrameWindow.document.open();
        loaderFrameWindow.document.write('<scr'+'ipt src="//hb.vntsm.com/v3/live/ad-manager.min.js" type="text/javascript" async>'+'</scr'+'ipt>');
        loaderFrameWindow.document.close();
    })();
</script>
<!-- / Venatus Market v3 -->
<!-- Venatus Market v3 - Videogamer - RICH MEDIA 1x1 -->
<div class="vm-placement" data-id="58d9240f46e0fb0001b87570" style="display: none"></div>
<!-- / Venatus Market v3 - Videogamer - RICH MEDIA 1x1 -->
<script defer="defer" src="/static/js/infrastructure.v3.js"></script><script defer="defer" src="/static/js/main.v3.js"></script><script>var pageConf = {base_url: 'www.videogamer.com',path: 'news/wwe-2k-promises-a-special-announcement-at-wrestlemania-this-weekend',page_group: 'article',page_title_site: '- VideoGamer.com',debug: false, content: {published_date: '2021-04-09',author: {permalink: 'benborthwick',name: 'Ben Borthwick'}},};dataLayer = [pageConf];</script><script type="application/ld+json">[{"@context":"http://schema.org","@type":"WebSite","name":"VideoGamer.com","url":"https://www.videogamer.com","sameAs":["https://twitter.com/VideoGamerCom","https://www.facebook.com/VideoGamerCom","https://www.youtube.com/VideoGamerTV"]},{"@context":"http://schema.org","publisher":{"@type":"Organization","name":"VideoGamer.com","url":"https:\/\/www.videogamer.com","logo":{"@type":"ImageObject","url":"https://www.videogamer.com/static/images/videogamer-web-black-sml.png","width":532,"height":60}},"datePublished":"2021-04-09T10:36:30+00:00","dateModified":"2021-04-09T10:36:30+00:00","author":{"@type":"Person","name":"Ben Borthwick"},"creator":["Ben Borthwick"],"mainEntityOfPage":{"@type":"WebPage","@id":"https://www.videogamer.com/news/wwe-2k-promises-a-special-announcement-at-wrestlemania-this-weekend"},"url":"https://www.videogamer.com/news/wwe-2k-promises-a-special-announcement-at-wrestlemania-this-weekend","description":"Could a WWE 2K22 reveal be imminent?","@type":"NewsArticle","headline":"WWE 2K promises a &#039;special announcement&#039; at Wrestlemania this weekend","articleSection":"News","image":{"@type":"ImageObject","contentUrl":"https://thumbs.videogamer.com/de6QsGUEqGpxlDSZNlFZGk4AJw0=/1920x1080/smart/https://s.videogamer.com/images/50ba/be860a0b-5371-4126-ad61-db5db976da90_ss_8d5da064e693c15c4c4750c07e39ca680b77261f.1920x1080.jpg","url":"https://thumbs.videogamer.com/de6QsGUEqGpxlDSZNlFZGk4AJw0=/1920x1080/smart/https://s.videogamer.com/images/50ba/be860a0b-5371-4126-ad61-db5db976da90_ss_8d5da064e693c15c4c4750c07e39ca680b77261f.1920x1080.jpg","width":1920,"height":1080},"thumbnailUrl":"https://thumbs.videogamer.com/de6QsGUEqGpxlDSZNlFZGk4AJw0=/1920x1080/smart/https://s.videogamer.com/images/50ba/be860a0b-5371-4126-ad61-db5db976da90_ss_8d5da064e693c15c4c4750c07e39ca680b77261f.1920x1080.jpg","keywords":["article","news"]}]</script></body></html>