<!doctype html><!--[if IE 8]> <html class="ie ie8" lang="en"> <![endif]--><!--[if gte IE 9]> <html class="no-js ie" lang="en"> <![endif]--><!--[if !IE]><!--> <html class="no-js" lang="en"> <!--<![endif]--><head><style scoped>@import "//fonts.googleapis.com/css?family=Droid+Sans:400,700|Noto+Serif:400,400i,700,700i"</style><title>Torchlight 3 gets winter-themed &#039;Snow &amp; Steam&#039; update next month - VideoGamer.com</title><link href="/static/css/style.v1.css" rel="stylesheet"><link href="//vjs.zencdn.net/5.8/video-js.min.css" rel="stylesheet"><meta name="description" content="Pretty cool stuff"><meta charset="UTF-8"/><meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1"><meta http-equiv="X-UA-Compatible" content="IE=Edge"><link rel="canonical" href="https://www.videogamer.com/news/torchlight-3-gets-winter-themed-snow--steam-update-next-month"><link rel="amphtml" href="https://www.videogamer.com/amp/news/torchlight-3-gets-winter-themed-snow--steam-update-next-month"><meta property="fb:app_id" content="121956104551901"><meta property="og:site_name" content="VideoGamer.com"><meta property="og:type" content="article"><meta property="og:title" content="Torchlight 3 gets winter-themed &#039;Snow &amp; Steam&#039; update next month - VideoGamer.com"><meta property="og:description" content="Pretty cool stuff"><meta property="og:locale" content="en_GB"><meta property="og:url" content="https://www.videogamer.com/news/torchlight-3-gets-winter-themed-snow--steam-update-next-month"><meta property="og:image" content="https://s.videogamer.com/meta/d66b/4a855138-ab7e-4d68-b4ff-ffc595405123_Torchlight3WinterUpdate.jpg"><link rel="apple-touch-icon" href="https://www.videogamer.com/static/images/apple-touch-icon.png" /><link rel="apple-touch-icon" sizes="72x72" href="https://www.videogamer.com/static/images/apple-touch-icon-72x72.png" /><link rel="apple-touch-icon" sizes="114x114" href="https://www.videogamer.com/static/images/apple-touch-icon-114x114.png" /><link rel="apple-touch-icon" sizes="144x144" href="https://www.videogamer.com/static/images/apple-touch-icon-144x144.png" /><meta name="twitter:card" content="summary" /><meta name="twitter:site" content="VideoGamerCom" /><meta name="twitter:title" content="Torchlight 3 gets winter-themed &#039;Snow &amp; Steam&#039; update next month - VideoGamer.com" /><meta name="twitter:description" content="Pretty cool stuff" /><meta name="twitter:image" content="https://s.videogamer.com/meta/d66b/4a855138-ab7e-4d68-b4ff-ffc595405123_Torchlight3WinterUpdate.jpg" /><link rel="shortcut icon" href="/static/images/favicon.ico"><link rel="icon" sizes="16x16 32x32 64x64" href="/static/images/favicon.ico"><link href="https://www.videogamer.com/rss/allupdates.xml" rel="alternate" type="application/rss+xml" title="VideoGamer.com - All Updates"></head><body class="l-maxwidth l-2column-sidebar js-sidebar-affix fixed-header" data-page-group="article"><div id="fb-root"></div><script src="/static/js/jquery-3.2.1.min.js"></script><script async src="https://www.googletagmanager.com/gtag/js?id=UA-3137559-1"></script><script>window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}gtag('js', new Date());gtag('config', 'UA-3137559-1',{ 'anonymize_ip': true });</script><header id="header" class="header header--border" role="banner"><div class="header__top u-clearfix" role="navigation"><div class="header__container"><nav><a href="/" title="VideoGamer.com" class="header-logo visible-md"><h1>VideoGamer.com</h1></a><div class="header-user-menu nav visible-md"><a class="header-user-menu__login" href="#" title="Login coming shortly."><span class="user-avatar user-avatar--placeholder"><svg role="presentation" class="icon icon-user" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-user"></use></svg></span></a><div class="header-user-menu__login-dd"><div class="temp"><h4>Registration and login are coming shortly.</h4><p>They're not quite ready yet. If you had an account with the old site, don't worry - it will be transferred over.</p></div></div></div><div class="header-navigation"><div class="header-navigation__search"><input type="text" id="gameSearch" title="Search" placeholder="Search"><button class="webicons search"><svg role="presentation" class="icon icon-search" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-search"></use></svg></button><ul class="search-dropdown plain-list scrollable" id="gameSearchList"></ul></div><ul class="nav"><li><a href="/news" title="News">News</a></li><li><a href="/videos" title="Videos">Videos</a></li><li><a href="/reviews" title="Reviews">Reviews</a></li><li class="visible-lg"><a href="/features" title="Features">Features</a></li><li class="invisible-md"><a href="/features" title="Features">Features</a></li><li><a href="/guides" title="Guides">Guides</a></li><li><a href="/podcasts" title="Podcast">Podcast</a></li><li class="invisible-md"><a href="/top-games" title="Top Games">Top Games</a></li><li><a href="/games" title="Games">Games</a></li><li><a href="/forums/" title="Forums">Forums</a></li><li class="visible-lg subscribe"><a href="https://www.patreon.com/VideoGamer" title="Patreon" rel="nofollow">Patreon</a></li><li class="invisible-md subscribe"><a href="https://www.patreon.com/VideoGamer" title="Patreon" rel="nofollow">Patreon</a></li></ul><ul class="nav invisible-md"><li><a href="/staff">Staff</a></li><li><a href="/contact-us">Contact Us</a></li><li><a href="/legal">Legal Info</a></li></ul><ul class="header-navigation__social nav invisible-md"><li><a href="http://www.youtube.com/videogamertv?sub_confirmation=1" class="square-icon social-icon--youtube"><svg role="presentation" class="icon icon-youtube2" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-youtube2"></use></svg></a></li><li><a href="https://twitter.com/intent/user?screen_name=VideoGamerCom" class="square-icon social-icon--twitter"><svg role="presentation" class="icon icon-twitter" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-twitter"></use></svg></a></li><li><a href="http://www.facebook.com/VideoGamerCom" class="square-icon social-icon--facebook"><svg role="presentation" class="icon icon-facebook" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-facebook"></use></svg></a></li><li><a href="/rss" class="square-icon social-icon--rss"><svg role="presentation" class="icon icon-rss" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-rss"></use></svg></a></li></ul></div></nav></div></div></header><div class="header-user-menu__user-dd--responsive"></div><div class="page-skin body_constrain"><div class="header--responsive invisible-md u-clearfix"><a href="/" title="VideoGamer.com" class="header-logo"><h1>VideoGamer.com</h1></a><div class="header--responsive__menu"><svg role="presentation" class="icon icon-bars" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-bars"></use></svg></div><div class="header-user-menu--responsive nav"><a class="header-user-menu__login--responsive" href="/login" title="Log In"><span class="avatar-placeholder"><svg role="presentation" class="icon icon-user" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-user"></use></svg></span></a></div></div>


<div align="center" style="margin-top:10px;"><!-- Venatus Market v3 - Videogamer - 728x90 Dynamic  --><div class="vm-placement" data-id="58d923eb46e0fb0001b87563"></div><!-- / Venatus Market v3 - Videogamer - 728x90 Dynamic --></div><div class="container u-clearfix article-base-page"><main class="main"><article class="article"><div class="article__social js-article-affix"><a href="https://twitter.com/intent/tweet?text=Torchlight%203%20gets%20winter-themed%20&#039;Snow%20&amp;%20Steam&#039;%20update%20next%20month&amp;url=https%3A%2F%2Fwww.videogamer.com%2Fnews%2Ftorchlight-3-gets-winter-themed-snow--steam-update-next-month" target="_blank" rel="nofollow" class="rounded-icon social-icon--twitter js-share-twitter"><svg role="presentation" class="icon icon-twitter" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-twitter"></use></svg></a><a href="https://www.facebook.com/dialog/share?app_id=121956104551901&amp;display=page&amp;href=https%3A%2F%2Fwww.videogamer.com%2Fnews%2Ftorchlight-3-gets-winter-themed-snow--steam-update-next-month" target="_blank" rel="nofollow" class="rounded-icon social-icon--facebook js-share-facebook"><svg role="presentation" class="icon icon-facebook" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-facebook"></use></svg></a></div><div class="article__section--gutter"><div class="article-head"><div class="user-avatar"><img src="/static/images/staff/202.jpg" alt="Ben Borthwick" /></div><div class="article-head__details"><p class="article-head__details__author article-meta">By <span><strong><span>Ben Borthwick</span></strong></span><span class="visible-inline-sm"> &nbsp;&bull;&nbsp; </span><span class="publish-date" title="2020-11-27 13:51:40">27 Nov 2020</span><span class="visible-inline-sm"> &nbsp;&bull;&nbsp; Posted in&nbsp;<a href="/news">News</a><span class="visible-inline-sm"> &nbsp;&bull;&nbsp; </span><span class="visible-inline-sm">Tagged in:&nbsp;<a href="/tag/torchlight-3">Torchlight 3</a>, <a href="/tag/torchlight">Torchlight</a>, <a href="/tag/perfect-world-entertainment">Perfect World Entertainment</a>, <a href="/tag/news">news</a><br></span></p><h1 class="article-head__details__headline editable255 tooltips article-headline" data-placeholder="Headline" data-name="headline">Torchlight 3 gets winter-themed &#039;Snow &amp; Steam&#039; update next month</h1></div><h2 class="article-head__subheadline editable255" data-placeholder="Subtitle" data-name="subtitle">Pretty cool stuff</h2></div></div><div class="article__section article__section--full article__section--leader select-embed-lead"><div class="oembed-image"><picture><source srcset="https://thumbs.videogamer.com/EQKdIYKvOUEpcRMDWB-2eX66F1k=/960x540/smart/filters:format(webp)/https://s.videogamer.com/meta/d66b/4a855138-ab7e-4d68-b4ff-ffc595405123_Torchlight3WinterUpdate.jpg 960w, https://thumbs.videogamer.com/y0y9E0sKnZRR8bjsE8iY59q3K5A=/640x360/smart/filters:format(webp)/https://s.videogamer.com/meta/d66b/4a855138-ab7e-4d68-b4ff-ffc595405123_Torchlight3WinterUpdate.jpg 640w, https://thumbs.videogamer.com/tqVXTKnoPZzUliEthykvmteW-6Y=/320x180/smart/filters:format(webp)/https://s.videogamer.com/meta/d66b/4a855138-ab7e-4d68-b4ff-ffc595405123_Torchlight3WinterUpdate.jpg 320w, https://thumbs.videogamer.com/6JJz6BkPDfiuRjk6Cw9xWM5gWV4=/120x68/smart/filters:format(webp)/https://s.videogamer.com/meta/d66b/4a855138-ab7e-4d68-b4ff-ffc595405123_Torchlight3WinterUpdate.jpg 120w" sizes="(min-width: 768px) 33.3vw, 100vw" type="images/webp"><img class="responsive-image" srcset="https://thumbs.videogamer.com/QIhBQdjmd616PeymBqNw4iyPxEo=/960x540/smart/https://s.videogamer.com/meta/d66b/4a855138-ab7e-4d68-b4ff-ffc595405123_Torchlight3WinterUpdate.jpg 960w, https://thumbs.videogamer.com/OIMvdkyhBIehjxqWvntzu6hF66c=/640x360/smart/https://s.videogamer.com/meta/d66b/4a855138-ab7e-4d68-b4ff-ffc595405123_Torchlight3WinterUpdate.jpg 640w, https://thumbs.videogamer.com/FOe-LP0eYzGm0kOOQk3k15pYSIY=/320x180/smart/https://s.videogamer.com/meta/d66b/4a855138-ab7e-4d68-b4ff-ffc595405123_Torchlight3WinterUpdate.jpg 320w, https://thumbs.videogamer.com/a5OMhji_APyFivRVYgumwSB7CzI=/120x68/smart/https://s.videogamer.com/meta/d66b/4a855138-ab7e-4d68-b4ff-ffc595405123_Torchlight3WinterUpdate.jpg 120w" src="https://thumbs.videogamer.com/paw485UgsFgnfbkzo9L8qtP-sOU=/320x180/smart/filters:no_upscale()/https://s.videogamer.com/meta/d66b/4a855138-ab7e-4d68-b4ff-ffc595405123_Torchlight3WinterUpdate.jpg" alt="Torchlight 3 gets winter-themed &amp;#039;Snow &amp;amp; Steam&amp;#039; update next month" sizes="(min-width: 768px) 33.3vw, 100vw"></picture></div></div><div class="article-body"><div class="article-mpu invisible-md"><div align="center"><!-- Venatus Market v3 - Videogamer - 300x250 Dynamic BTF --><div class="vm-placement" data-id="58d9240346e0fb0001b8756e"></div><!-- / Venatus Market v3 - Videogamer - 300x250 Dynamic BTF --></div></div><section><div class="article__section article__section--gutter"><p>Dungeon crawler <em>Torchlight 3</em> will be getting its &#39;Snow &amp; Steam&#39; update next month, bringing a bunch of seasonally-appropriate decorations and cosmetics, as well as a rework for the Forged class and much more.</p>

<p>As detailed&nbsp;<a href="https://www.torchlight3.com/en/news-article/11481383" target="_blank">on the <em>Torchlight 3</em> website</a>, the update will add a new Contract offering a wealth of winter themed pets and fort decorations, including a Holiday Tree and even an&nbsp;Ugly Sweater for your&nbsp;cat.&nbsp; There&#39;s also some new ice-based Legendary Weapons which will be added to the game alongside a new armour set for intreprid endgame-levelled players (47-60)&nbsp;to find while exploring the Frontier.&nbsp;</p>

<p>Elsewhere, a new Style Station will be available for your dungeon to give your heroes a new look, while the new Fort Basements will offer you more room in your home fort as well as the ability to place fort decorations vertically. The Forged rework meanwhile overhauls the UI, and while more details will be revealed closer to the update&#39;s launch, Echtra promise it&#39;ll make the class &quot;more interesting and viable&quot; to play as.&nbsp;</p>

<p>There&#39;s a bunch of other tweaks and enhancements promised to be coming along too including the ability to allow&nbsp;pets to fetch potions and the team will be addressing drop rates, movement skills and a bunch of fixes. For now, you can check out a trailer for the forthcoming update below.</p>

<p>The Snow &amp; Steam update will be landing in mid-December for <em>Torchlight 3 </em>on Xbox One, PlayStation 4, Nintendo Switch and PC.</p>

<div class="youtube-embed-wrapper" style="position:relative;padding-bottom:56.25%;padding-top:30px;height:0;overflow:hidden"><iframe allowfullscreen="" frameborder="0" height="360" src="https://www.youtube-nocookie.com/embed/ncMezsTt-LY" style="position:absolute;top:0;left:0;width:100%;height:100%" width="640"></iframe></div>

<p>&nbsp;</p>
</div></section><div align="center"><div id="ultimedia_wrapper"></div><script type="text/javascript">var ULTIMEDIA_mdtk = "02461417" ;var ULTIMEDIA_zone= "2";var ULTIMEDIA_target = "ultimedia_wrapper";var ULTIMEDIA_async = false;</script><script type="text/javascript" src="https://www.ultimedia.com/js/common/smart.js"></script></div><div align="center"><a href="/forums/" class="breaker__seeall btn btn-primary" alt="Video Gamer Forums">Carry on the conversation on the VideoGamer forums!</a><style type="text/css">.btn-primary:hover{background-color:black;}</style></div><div align="center"><!-- Venatus Market v3 - Videogamer - 300x250 Dynamic BTF --><div class="vm-placement" data-id="58d9240346e0fb0001b8756e"></div><!-- / Venatus Market v3 - Videogamer - 300x250 Dynamic BTF --></div></div><div class="article__footer u-clearfix clearboth"><div class="hr margin-block"></div><div class="u-clearBoth margin-block"><a href="https://twitter.com/intent/tweet?text=Torchlight%203%20gets%20winter-themed%20&#039;Snow%20&amp;%20Steam&#039;%20update%20next%20month&amp;url=https%3A%2F%2Fwww.videogamer.com%2Fnews%2Ftorchlight-3-gets-winter-themed-snow--steam-update-next-month" target="_blank" rel="nofollow" class="rounded-icon social-icon--twitter js-share-twitter"><svg role="presentation" class="icon icon-twitter" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-twitter"></use></svg></a><a href="https://www.facebook.com/dialog/share?app_id=121956104551901&amp;display=page&amp;href=https%3A%2F%2Fwww.videogamer.com%2Fnews%2Ftorchlight-3-gets-winter-themed-snow--steam-update-next-month" target="_blank" rel="nofollow" class="rounded-icon social-icon--facebook js-share-facebook"><svg role="presentation" class="icon icon-facebook" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-facebook"></use></svg></a></div></div></article></main><aside class="sidebar"></aside><div class="sidebar_contents sidebar_contents--foot aside"><div align="center"><!-- Venatus Market v3 - Videogamer - 300x250 Dynamic ATF --><div class="vm-placement" data-id="58d923fb46e0fb0001b87569"></div><!-- / Venatus Market v3 - Videogamer - 300x250 Dynamic ATF --></div><div class="mentioned-games"><div class="mentioned-games__item mentioned-games__item--single"><h3 itemprop="name"><a href="/games/torchlight-iii">Torchlight III</a></h3><div class="u-clearBoth"><div class="mentioned-games__item__platforms"><strong>on </strong><span>PC, </span><span>PlayStation 4, </span><span>Xbox One</span></div><div class="mentioned-games__item__body"><a href="/games/torchlight-iii" class="box-link"><picture><source srcset="https://thumbs.videogamer.com/B19ehrn0kN3bViISc_j3cGrCMwU=/160x/filters:format(webp)/https://s.videogamer.com/meta/6bfd/356b032b-a64c-4aaa-8014-dd5c25472de4_300_(2).jfif 160w, https://thumbs.videogamer.com/jTgnkr6UXS0WThdQwu4R_m6xDj4=/120x/filters:format(webp)/https://s.videogamer.com/meta/6bfd/356b032b-a64c-4aaa-8014-dd5c25472de4_300_(2).jfif 120w" sizes="(min-width: 992px) 15vw, 33.3vw" type="images/webp"><img class="responsive-image" srcset="https://thumbs.videogamer.com/yT_g5z9N8mhBQPVRtNFMc0_ccgg=/160x/https://s.videogamer.com/meta/6bfd/356b032b-a64c-4aaa-8014-dd5c25472de4_300_(2).jfif 160w, https://thumbs.videogamer.com/DrOAT88BYSnKvx8bHCYBzrlTgIk=/120x/https://s.videogamer.com/meta/6bfd/356b032b-a64c-4aaa-8014-dd5c25472de4_300_(2).jfif 120w" src="https://thumbs.videogamer.com/55eR49OubcIoznT_HQXXsFYDRnU=/240x/filters:no_upscale()/https://s.videogamer.com/meta/6bfd/356b032b-a64c-4aaa-8014-dd5c25472de4_300_(2).jfif" alt="Torchlight III" sizes="(min-width: 992px) 15vw, 33.3vw"></picture></a><span itemprop="description"><em>No description yet...</em></span></div><div class="mentioned-games__item__release"><strong>First Released:</strong> 31 December 2020</div><a href="/games/torchlight-iii" class="btn btn-visit-gamespace"><span class="btn-visit-gamespace__icon">g</span>Visit game space</a><a href="http://www.amazon.co.uk/gp/search?ie=UTF8&amp;camp=1634&amp;tag=prog-21&amp;creative=6738&amp;index=videogames&amp;keywords=Torchlight III&amp;linkCode=ur2" class="btn-buy-amazon mentioned-games__item__buy" target="_blank" rel="nofollow"><span class="amazon-logo"><svg width="100%" height="100%"><image xlink:href="/static/images/amazon.svg" src="/static/images/amazon.svg" width="100%" height="100%" /></svg></span><span class="check-prices">Check Prices</span></a></div></div><div align="center"><!-- Venatus Market v3 - Videogamer - 300x250 Dynamic BTF --><div class="vm-placement" data-id="58d9240346e0fb0001b8756e"></div><!-- / Venatus Market v3 - Videogamer - 300x250 Dynamic BTF --></div><section class="sidebar_item popular-articles"><h2>Popular Now</h2><ul class="content-list content-list--aside"><li class="content-item"><a href="/news/assassins-creed-valhalla-update-brings-graphicsperformance-mode-option--more"><div class="content-item__image"><picture><source srcset="https://thumbs.videogamer.com/7n-LstP-BsaItk6mPOTplEiTxsw=/640x360/smart/filters:format(webp)/https://s.videogamer.com/images/379c/c08679d6-446e-43bd-90b1-37f20fefb023_Assassins-Creed-Valhalla_2020_07-12-20_008.jpg 640w, https://thumbs.videogamer.com/GLaCCDGyoVo1bfCeYO9SOrWLjeA=/320x180/smart/filters:format(webp)/https://s.videogamer.com/images/379c/c08679d6-446e-43bd-90b1-37f20fefb023_Assassins-Creed-Valhalla_2020_07-12-20_008.jpg 320w, https://thumbs.videogamer.com/DAttIw4YcJhSEg8mkZTGapOgDgo=/120x68/smart/filters:format(webp)/https://s.videogamer.com/images/379c/c08679d6-446e-43bd-90b1-37f20fefb023_Assassins-Creed-Valhalla_2020_07-12-20_008.jpg 120w" sizes="20vw" type="images/webp"><img class="responsive-image" srcset="https://thumbs.videogamer.com/FNYLantJAC_RLYTJM6tcD9mmxV4=/640x360/smart/https://s.videogamer.com/images/379c/c08679d6-446e-43bd-90b1-37f20fefb023_Assassins-Creed-Valhalla_2020_07-12-20_008.jpg 640w, https://thumbs.videogamer.com/KYW7eNn2mFAsLa5_ym10hXjsm9Y=/320x180/smart/https://s.videogamer.com/images/379c/c08679d6-446e-43bd-90b1-37f20fefb023_Assassins-Creed-Valhalla_2020_07-12-20_008.jpg 320w, https://thumbs.videogamer.com/5LQVHjeh8swpiznifoYXqrEq6vI=/120x68/smart/https://s.videogamer.com/images/379c/c08679d6-446e-43bd-90b1-37f20fefb023_Assassins-Creed-Valhalla_2020_07-12-20_008.jpg 120w" src="https://thumbs.videogamer.com/IxXUuZLMkKn3BmI2OvRdYhymZoA=/320x240/smart/filters:no_upscale()/https://s.videogamer.com/images/379c/c08679d6-446e-43bd-90b1-37f20fefb023_Assassins-Creed-Valhalla_2020_07-12-20_008.jpg" alt="Assassin&amp;#039;s Creed Valhalla update brings Graphics/Performance mode option &amp; more" sizes="20vw"></picture><span class="content-item__article-type">NEWS</span></div><div class="content-item__details"><h3>Assassin's Creed Valhalla update brings Graphics/Performance mode option & more</h3></div></a></li><li class="content-item"><a href="/news/mortal-kombat-11-gets-the-original-1995-movie-cast-as-its-latest-dlc"><div class="content-item__image"><picture><source srcset="https://thumbs.videogamer.com/vvhPZXphO65Ubh8sJStuqIkpIXk=/640x360/smart/filters:format(webp)/https://s.videogamer.com/meta/f5e6/470e8304-2bc3-4bfa-8867-775ade67caf6_ChristopherLambertMK11.jpg 640w, https://thumbs.videogamer.com/xVv2Om4az8o_W5xf7CA2fZ6Kzj0=/320x180/smart/filters:format(webp)/https://s.videogamer.com/meta/f5e6/470e8304-2bc3-4bfa-8867-775ade67caf6_ChristopherLambertMK11.jpg 320w, https://thumbs.videogamer.com/FdBu6xUVlLieEm932dGRSGhVbHI=/120x68/smart/filters:format(webp)/https://s.videogamer.com/meta/f5e6/470e8304-2bc3-4bfa-8867-775ade67caf6_ChristopherLambertMK11.jpg 120w" sizes="20vw" type="images/webp"><img class="responsive-image" srcset="https://thumbs.videogamer.com/2if4mXgaxAyEXO1yh41efy166zM=/640x360/smart/https://s.videogamer.com/meta/f5e6/470e8304-2bc3-4bfa-8867-775ade67caf6_ChristopherLambertMK11.jpg 640w, https://thumbs.videogamer.com/tu12C7Ru58E4CME3PxAHgp1mzyo=/320x180/smart/https://s.videogamer.com/meta/f5e6/470e8304-2bc3-4bfa-8867-775ade67caf6_ChristopherLambertMK11.jpg 320w, https://thumbs.videogamer.com/Rn7X_Qv-4Z2ELnqYKQHzvVqLUfs=/120x68/smart/https://s.videogamer.com/meta/f5e6/470e8304-2bc3-4bfa-8867-775ade67caf6_ChristopherLambertMK11.jpg 120w" src="https://thumbs.videogamer.com/sv2uNvQ3xdq3UaMNjfuZUh5zezw=/320x240/smart/filters:no_upscale()/https://s.videogamer.com/meta/f5e6/470e8304-2bc3-4bfa-8867-775ade67caf6_ChristopherLambertMK11.jpg" alt="Mortal Kombat 11 gets the original 1995 movie cast as its latest DLC" sizes="20vw"></picture><span class="content-item__article-type">NEWS</span></div><div class="content-item__details"><h3>Mortal Kombat 11 gets the original 1995 movie cast as its latest DLC</h3></div></a></li><li class="content-item"><a href="/news/worms-rumble-rocket-arena--just-cause-4-are-free-on-ps-plus-for-december"><div class="content-item__image"><picture><source srcset="https://thumbs.videogamer.com/uyvs_L2lcDPZcfyjThhfXca0az4=/640x360/smart/filters:format(webp)/https://s.videogamer.com/meta/3fd7/198614c7-e069-4e17-8074-59d186e103ab_PSPlusDec2020.jpg 640w, https://thumbs.videogamer.com/kNhSbymlaUUNwLEA2xNR1E4NeZY=/320x180/smart/filters:format(webp)/https://s.videogamer.com/meta/3fd7/198614c7-e069-4e17-8074-59d186e103ab_PSPlusDec2020.jpg 320w, https://thumbs.videogamer.com/1oASUP_giwa71ajaCG1fE2yKkm8=/120x68/smart/filters:format(webp)/https://s.videogamer.com/meta/3fd7/198614c7-e069-4e17-8074-59d186e103ab_PSPlusDec2020.jpg 120w" sizes="20vw" type="images/webp"><img class="responsive-image" srcset="https://thumbs.videogamer.com/7nlN0cF6pGmmZz_YD47d9LeHphI=/640x360/smart/https://s.videogamer.com/meta/3fd7/198614c7-e069-4e17-8074-59d186e103ab_PSPlusDec2020.jpg 640w, https://thumbs.videogamer.com/JdIKkRXITQIMVHuYhBNzGLBYkdo=/320x180/smart/https://s.videogamer.com/meta/3fd7/198614c7-e069-4e17-8074-59d186e103ab_PSPlusDec2020.jpg 320w, https://thumbs.videogamer.com/DWRsEBnziN8R3ZxgbzZ3XccVy-8=/120x68/smart/https://s.videogamer.com/meta/3fd7/198614c7-e069-4e17-8074-59d186e103ab_PSPlusDec2020.jpg 120w" src="https://thumbs.videogamer.com/U37Jwc4rmJHf13BeWryigiyy78M=/320x240/smart/filters:no_upscale()/https://s.videogamer.com/meta/3fd7/198614c7-e069-4e17-8074-59d186e103ab_PSPlusDec2020.jpg" alt="Worms Rumble, Rocket Arena &amp; Just Cause 4 are free on PS Plus for December" sizes="20vw"></picture><span class="content-item__article-type">NEWS</span></div><div class="content-item__details"><h3>Worms Rumble, Rocket Arena & Just Cause 4 are free on PS Plus for December</h3></div></a></li><li class="content-item"><a href="/news/sony-promises-more-playstation-5-consoles-coming-to-retailers-before-the-end-of-the-year"><div class="content-item__image"><picture><source srcset="https://thumbs.videogamer.com/Wd8lyeMGA_Rray2X7xE77iqwq8w=/640x360/smart/filters:format(webp)/https://s.videogamer.com/meta/0542/5d215c94-637e-4e1d-904c-b5508c2ca0c2_bf051fcb-ce42-4757-9f0d-5ec3018b3860_PS5_real.jpg 640w, https://thumbs.videogamer.com/-kePahpnoqRYAGDvH-wjdtZ3K1Q=/320x180/smart/filters:format(webp)/https://s.videogamer.com/meta/0542/5d215c94-637e-4e1d-904c-b5508c2ca0c2_bf051fcb-ce42-4757-9f0d-5ec3018b3860_PS5_real.jpg 320w, https://thumbs.videogamer.com/_U595prvcrCqAWrdgCZBR7y98wU=/120x68/smart/filters:format(webp)/https://s.videogamer.com/meta/0542/5d215c94-637e-4e1d-904c-b5508c2ca0c2_bf051fcb-ce42-4757-9f0d-5ec3018b3860_PS5_real.jpg 120w" sizes="20vw" type="images/webp"><img class="responsive-image" srcset="https://thumbs.videogamer.com/wz42Yy6jvQbvotO2v2Qja7pD3Gg=/640x360/smart/https://s.videogamer.com/meta/0542/5d215c94-637e-4e1d-904c-b5508c2ca0c2_bf051fcb-ce42-4757-9f0d-5ec3018b3860_PS5_real.jpg 640w, https://thumbs.videogamer.com/b8ejxhPdQbbMYzACT0hl_BPyv3U=/320x180/smart/https://s.videogamer.com/meta/0542/5d215c94-637e-4e1d-904c-b5508c2ca0c2_bf051fcb-ce42-4757-9f0d-5ec3018b3860_PS5_real.jpg 320w, https://thumbs.videogamer.com/OztJIo6Nxv_AQE8P-qJWtAbvno4=/120x68/smart/https://s.videogamer.com/meta/0542/5d215c94-637e-4e1d-904c-b5508c2ca0c2_bf051fcb-ce42-4757-9f0d-5ec3018b3860_PS5_real.jpg 120w" src="https://thumbs.videogamer.com/CW29VkFLGsWLOm3T7k5hTNV36LE=/320x240/smart/filters:no_upscale()/https://s.videogamer.com/meta/0542/5d215c94-637e-4e1d-904c-b5508c2ca0c2_bf051fcb-ce42-4757-9f0d-5ec3018b3860_PS5_real.jpg" alt="Sony promises more PlayStation 5 consoles coming to retailers "before the end of the year"" sizes="20vw"></picture><span class="content-item__article-type">NEWS</span></div><div class="content-item__details"><h3>Sony promises more PlayStation 5 consoles coming to retailers "before the end of the year"</h3></div></a></li><li class="content-item"><a href="/news/xbox-addresses-reported-performance-issues-on-third-party-titles-on-xbox-series-xs"><div class="content-item__image"><picture><source srcset="https://thumbs.videogamer.com/K2CGLeGylggvODiHDsnx-WR4TMU=/640x360/smart/filters:format(webp)/https://s.videogamer.com/meta/3be2/9a9f7915-5d69-4299-b56d-2fee1fc61f56_82e1605c-0f90-4ebb-bc74-0fac8e1a7f46_7318efa5-2fc9-4b73-b161-419698f22fde_XboxSeriesSXConsolesFrontView.jpg 640w, https://thumbs.videogamer.com/Cg2-ylcRDHyzplRGKxnKjkZER2A=/320x180/smart/filters:format(webp)/https://s.videogamer.com/meta/3be2/9a9f7915-5d69-4299-b56d-2fee1fc61f56_82e1605c-0f90-4ebb-bc74-0fac8e1a7f46_7318efa5-2fc9-4b73-b161-419698f22fde_XboxSeriesSXConsolesFrontView.jpg 320w, https://thumbs.videogamer.com/PUFcukz67IHADTzntp4_vadcS1g=/120x68/smart/filters:format(webp)/https://s.videogamer.com/meta/3be2/9a9f7915-5d69-4299-b56d-2fee1fc61f56_82e1605c-0f90-4ebb-bc74-0fac8e1a7f46_7318efa5-2fc9-4b73-b161-419698f22fde_XboxSeriesSXConsolesFrontView.jpg 120w" sizes="20vw" type="images/webp"><img class="responsive-image" srcset="https://thumbs.videogamer.com/3ZQS-4uBza3_6-CADjh-qFXm1gQ=/640x360/smart/https://s.videogamer.com/meta/3be2/9a9f7915-5d69-4299-b56d-2fee1fc61f56_82e1605c-0f90-4ebb-bc74-0fac8e1a7f46_7318efa5-2fc9-4b73-b161-419698f22fde_XboxSeriesSXConsolesFrontView.jpg 640w, https://thumbs.videogamer.com/6BMItPpWh4gk9bGc-OytFVMYWfI=/320x180/smart/https://s.videogamer.com/meta/3be2/9a9f7915-5d69-4299-b56d-2fee1fc61f56_82e1605c-0f90-4ebb-bc74-0fac8e1a7f46_7318efa5-2fc9-4b73-b161-419698f22fde_XboxSeriesSXConsolesFrontView.jpg 320w, https://thumbs.videogamer.com/koRNJMjjiA388Fk1w8LzFTPi8Ys=/120x68/smart/https://s.videogamer.com/meta/3be2/9a9f7915-5d69-4299-b56d-2fee1fc61f56_82e1605c-0f90-4ebb-bc74-0fac8e1a7f46_7318efa5-2fc9-4b73-b161-419698f22fde_XboxSeriesSXConsolesFrontView.jpg 120w" src="https://thumbs.videogamer.com/mnbjJEpIcGpgFXl_GRPRynaZeoA=/320x240/smart/filters:no_upscale()/https://s.videogamer.com/meta/3be2/9a9f7915-5d69-4299-b56d-2fee1fc61f56_82e1605c-0f90-4ebb-bc74-0fac8e1a7f46_7318efa5-2fc9-4b73-b161-419698f22fde_XboxSeriesSXConsolesFrontView.jpg" alt="Xbox addresses reported performance issues on third-party titles on Xbox Series X|S" sizes="20vw"></picture><span class="content-item__article-type">NEWS</span></div><div class="content-item__details"><h3>Xbox addresses reported performance issues on third-party titles on Xbox Series X|S</h3></div></a></li><li class="content-item"><a href="/news/pokemon-teasing-very-special-25th-anniversary-celebrations-next-year"><div class="content-item__image"><picture><source srcset="https://thumbs.videogamer.com/UNAOTvCs9tsf1kflZrTPobHLbFk=/640x360/smart/filters:format(webp)/https://s.videogamer.com/meta/dcb7/84015eaa-12d9-42b0-ab2d-0ff6b8b5abcd_Pokemon25.jpg 640w, https://thumbs.videogamer.com/nmSQSkLofVhO35-ak7PVG4jLGg8=/320x180/smart/filters:format(webp)/https://s.videogamer.com/meta/dcb7/84015eaa-12d9-42b0-ab2d-0ff6b8b5abcd_Pokemon25.jpg 320w, https://thumbs.videogamer.com/lr-dSF29DZyQFqhpr6_o0WutgQ0=/120x68/smart/filters:format(webp)/https://s.videogamer.com/meta/dcb7/84015eaa-12d9-42b0-ab2d-0ff6b8b5abcd_Pokemon25.jpg 120w" sizes="20vw" type="images/webp"><img class="responsive-image" srcset="https://thumbs.videogamer.com/1NbQDaEwijskaAP57l-lj-l5naY=/640x360/smart/https://s.videogamer.com/meta/dcb7/84015eaa-12d9-42b0-ab2d-0ff6b8b5abcd_Pokemon25.jpg 640w, https://thumbs.videogamer.com/EP9144NkUvAZftd4fsBW-Xj2r6A=/320x180/smart/https://s.videogamer.com/meta/dcb7/84015eaa-12d9-42b0-ab2d-0ff6b8b5abcd_Pokemon25.jpg 320w, https://thumbs.videogamer.com/eilxVXE7_VAsYaJFGhRF9DDo6bA=/120x68/smart/https://s.videogamer.com/meta/dcb7/84015eaa-12d9-42b0-ab2d-0ff6b8b5abcd_Pokemon25.jpg 120w" src="https://thumbs.videogamer.com/lDV4dYd7ozqhDza9XrjsMXumPbQ=/320x240/smart/filters:no_upscale()/https://s.videogamer.com/meta/dcb7/84015eaa-12d9-42b0-ab2d-0ff6b8b5abcd_Pokemon25.jpg" alt="Pokemon teasing "very special" 25th anniversary celebrations next year" sizes="20vw"></picture><span class="content-item__article-type">NEWS</span></div><div class="content-item__details"><h3>Pokemon teasing "very special" 25th anniversary celebrations next year</h3></div></a></li><li class="content-item"><a href="/news/kingpin-reloaded-delayed-into-2021-as-it-plans-to-reverse-engineer-the-original"><div class="content-item__image"><picture><source srcset="https://thumbs.videogamer.com/lv0F1fJZGdRnfXjTJ_OJIMx2ePk=/640x360/smart/filters:format(webp)/https://s.videogamer.com/images/d9f1/8bc9af49-654f-4978-b713-7f29f626e572_KingpinReloaded_1.png 640w, https://thumbs.videogamer.com/opnNGfsJ6LrDV4CnfScXvnJIQek=/320x180/smart/filters:format(webp)/https://s.videogamer.com/images/d9f1/8bc9af49-654f-4978-b713-7f29f626e572_KingpinReloaded_1.png 320w, https://thumbs.videogamer.com/AmtwUzIcbMTJuQZimAAAWAdeXcM=/120x68/smart/filters:format(webp)/https://s.videogamer.com/images/d9f1/8bc9af49-654f-4978-b713-7f29f626e572_KingpinReloaded_1.png 120w" sizes="20vw" type="images/webp"><img class="responsive-image" srcset="https://thumbs.videogamer.com/SEbIRmCGuVdNnhZJfT4c9tTYPGU=/640x360/smart/https://s.videogamer.com/images/d9f1/8bc9af49-654f-4978-b713-7f29f626e572_KingpinReloaded_1.png 640w, https://thumbs.videogamer.com/NFF4pvHcHatHh5OBYmdIB7K_wGU=/320x180/smart/https://s.videogamer.com/images/d9f1/8bc9af49-654f-4978-b713-7f29f626e572_KingpinReloaded_1.png 320w, https://thumbs.videogamer.com/dMxngY92ZcQI-Lf8KXxQoHkyEnM=/120x68/smart/https://s.videogamer.com/images/d9f1/8bc9af49-654f-4978-b713-7f29f626e572_KingpinReloaded_1.png 120w" src="https://thumbs.videogamer.com/KzAYI7K0qpE8kiWlrgLIK8vOcT8=/320x240/smart/filters:no_upscale()/https://s.videogamer.com/images/d9f1/8bc9af49-654f-4978-b713-7f29f626e572_KingpinReloaded_1.png" alt="Kingpin: Reloaded delayed into 2021 as it plans to reverse engineer the original" sizes="20vw"></picture><span class="content-item__article-type">NEWS</span></div><div class="content-item__details"><h3>Kingpin: Reloaded delayed into 2021 as it plans to reverse engineer the original</h3></div></a></li><li class="content-item"><a href="/news/cyberpunk-2077-offers-look-at-nomad-lifepath-on-ps4-pro--playstation-5"><div class="content-item__image"><picture><source srcset="https://thumbs.videogamer.com/-pxNUoYYod__ENuup1lvvq_EkVw=/640x360/smart/filters:format(webp)/https://s.videogamer.com/images/f205/e405f582-001b-4e9b-8f0b-3e8c34d0adbf_Cyberpunk-2077_2020_08-10-20_006.jpg 640w, https://thumbs.videogamer.com/3lPWllbwzVMjlXj9PcMPFOjzLg4=/320x180/smart/filters:format(webp)/https://s.videogamer.com/images/f205/e405f582-001b-4e9b-8f0b-3e8c34d0adbf_Cyberpunk-2077_2020_08-10-20_006.jpg 320w, https://thumbs.videogamer.com/9jWgjnuwUbNhJD8wM2poOe25jT4=/120x68/smart/filters:format(webp)/https://s.videogamer.com/images/f205/e405f582-001b-4e9b-8f0b-3e8c34d0adbf_Cyberpunk-2077_2020_08-10-20_006.jpg 120w" sizes="20vw" type="images/webp"><img class="responsive-image" srcset="https://thumbs.videogamer.com/1gzffksmhLX_QwVLwsqgDNTQOJo=/640x360/smart/https://s.videogamer.com/images/f205/e405f582-001b-4e9b-8f0b-3e8c34d0adbf_Cyberpunk-2077_2020_08-10-20_006.jpg 640w, https://thumbs.videogamer.com/sCFQ5yogasFAIfv0NMqGxg62tog=/320x180/smart/https://s.videogamer.com/images/f205/e405f582-001b-4e9b-8f0b-3e8c34d0adbf_Cyberpunk-2077_2020_08-10-20_006.jpg 320w, https://thumbs.videogamer.com/U8Dfg_VIzhr1qqVYU_VZMrXJOgE=/120x68/smart/https://s.videogamer.com/images/f205/e405f582-001b-4e9b-8f0b-3e8c34d0adbf_Cyberpunk-2077_2020_08-10-20_006.jpg 120w" src="https://thumbs.videogamer.com/dIa2xeZzdYgx7AYr3X_HFTjpFb0=/320x240/smart/filters:no_upscale()/https://s.videogamer.com/images/f205/e405f582-001b-4e9b-8f0b-3e8c34d0adbf_Cyberpunk-2077_2020_08-10-20_006.jpg" alt="Cyberpunk 2077 offers look at Nomad lifepath on PS4 Pro &amp; PlayStation 5" sizes="20vw"></picture><span class="content-item__article-type">NEWS</span></div><div class="content-item__details"><h3>Cyberpunk 2077 offers look at Nomad lifepath on PS4 Pro & PlayStation 5</h3></div></a></li><li class="content-item"><a href="/news/playstation-5-scalpers-reportedly-to-blame-for-uk-stock-shortages"><div class="content-item__image"><picture><source srcset="https://thumbs.videogamer.com/3lCRbBvbpJwL3ybOB_B0jsbV6Hg=/640x360/smart/filters:format(webp)/https://s.videogamer.com/meta/9571/53414589-397a-4dcb-bccb-cb2385094ed2_1a310ad4-6d55-4745-876a-0f2a693262fe_6ec88b3b-62c4-45b6-b678-68a1aad66949_375c5095-6c91-48ae-a44f-eb89551cc2fa_playstation-5-side.jpg 640w, https://thumbs.videogamer.com/xgbBLJCZvvhbKStKNFaeDAYQeKg=/320x180/smart/filters:format(webp)/https://s.videogamer.com/meta/9571/53414589-397a-4dcb-bccb-cb2385094ed2_1a310ad4-6d55-4745-876a-0f2a693262fe_6ec88b3b-62c4-45b6-b678-68a1aad66949_375c5095-6c91-48ae-a44f-eb89551cc2fa_playstation-5-side.jpg 320w, https://thumbs.videogamer.com/SwF818Rey2SUiNraQi2Irw9Hf94=/120x68/smart/filters:format(webp)/https://s.videogamer.com/meta/9571/53414589-397a-4dcb-bccb-cb2385094ed2_1a310ad4-6d55-4745-876a-0f2a693262fe_6ec88b3b-62c4-45b6-b678-68a1aad66949_375c5095-6c91-48ae-a44f-eb89551cc2fa_playstation-5-side.jpg 120w" sizes="20vw" type="images/webp"><img class="responsive-image" srcset="https://thumbs.videogamer.com/P1c6KY0VSb3Pg55gQt2g2t0QUf4=/640x360/smart/https://s.videogamer.com/meta/9571/53414589-397a-4dcb-bccb-cb2385094ed2_1a310ad4-6d55-4745-876a-0f2a693262fe_6ec88b3b-62c4-45b6-b678-68a1aad66949_375c5095-6c91-48ae-a44f-eb89551cc2fa_playstation-5-side.jpg 640w, https://thumbs.videogamer.com/JOVNRQ5SfOGGpVClT9ftO1HPcYw=/320x180/smart/https://s.videogamer.com/meta/9571/53414589-397a-4dcb-bccb-cb2385094ed2_1a310ad4-6d55-4745-876a-0f2a693262fe_6ec88b3b-62c4-45b6-b678-68a1aad66949_375c5095-6c91-48ae-a44f-eb89551cc2fa_playstation-5-side.jpg 320w, https://thumbs.videogamer.com/HyWeEVzK_tNTD_i1vUAnfPAI1AY=/120x68/smart/https://s.videogamer.com/meta/9571/53414589-397a-4dcb-bccb-cb2385094ed2_1a310ad4-6d55-4745-876a-0f2a693262fe_6ec88b3b-62c4-45b6-b678-68a1aad66949_375c5095-6c91-48ae-a44f-eb89551cc2fa_playstation-5-side.jpg 120w" src="https://thumbs.videogamer.com/xBp2vSEPvpEnGRG6HPcPPGaAgl4=/320x240/smart/filters:no_upscale()/https://s.videogamer.com/meta/9571/53414589-397a-4dcb-bccb-cb2385094ed2_1a310ad4-6d55-4745-876a-0f2a693262fe_6ec88b3b-62c4-45b6-b678-68a1aad66949_375c5095-6c91-48ae-a44f-eb89551cc2fa_playstation-5-side.jpg" alt="PlayStation 5 scalpers reportedly to blame for UK stock shortages" sizes="20vw"></picture><span class="content-item__article-type">NEWS</span></div><div class="content-item__details"><h3>PlayStation 5 scalpers reportedly to blame for UK stock shortages</h3></div></a></li><li class="content-item"><a href="/news/fallout-76-releases-steel-dawn-expansion-a-week-early-thanks-to-technical-glitch"><div class="content-item__image"><picture><source srcset="https://thumbs.videogamer.com/X2mrIF1JJlBDPZE2ZafmPeCxYhk=/640x360/smart/filters:format(webp)/https://s.videogamer.com/meta/036a/1159b006-d50d-44f1-83b1-8b3098850866_472214e9-9e28-47f3-b442-6ba4bfe57a0d_Fallout76SteelDawn.jpg 640w, https://thumbs.videogamer.com/YYBXycLNS-o-5lz1SG-jurSfuFg=/320x180/smart/filters:format(webp)/https://s.videogamer.com/meta/036a/1159b006-d50d-44f1-83b1-8b3098850866_472214e9-9e28-47f3-b442-6ba4bfe57a0d_Fallout76SteelDawn.jpg 320w, https://thumbs.videogamer.com/Cc4-X-ZK4t9341puIKNrfNMxFBs=/120x68/smart/filters:format(webp)/https://s.videogamer.com/meta/036a/1159b006-d50d-44f1-83b1-8b3098850866_472214e9-9e28-47f3-b442-6ba4bfe57a0d_Fallout76SteelDawn.jpg 120w" sizes="20vw" type="images/webp"><img class="responsive-image" srcset="https://thumbs.videogamer.com/h0rgpPi8i4yvATE3Tta8Prm7UNM=/640x360/smart/https://s.videogamer.com/meta/036a/1159b006-d50d-44f1-83b1-8b3098850866_472214e9-9e28-47f3-b442-6ba4bfe57a0d_Fallout76SteelDawn.jpg 640w, https://thumbs.videogamer.com/n2j5W33XEcFkH76eZYiixh8oNtI=/320x180/smart/https://s.videogamer.com/meta/036a/1159b006-d50d-44f1-83b1-8b3098850866_472214e9-9e28-47f3-b442-6ba4bfe57a0d_Fallout76SteelDawn.jpg 320w, https://thumbs.videogamer.com/Zc_hOenFx__GFydzeQaV9MPfIDM=/120x68/smart/https://s.videogamer.com/meta/036a/1159b006-d50d-44f1-83b1-8b3098850866_472214e9-9e28-47f3-b442-6ba4bfe57a0d_Fallout76SteelDawn.jpg 120w" src="https://thumbs.videogamer.com/4DVHWBJYJuRcJFq637LXxxwHI9Y=/320x240/smart/filters:no_upscale()/https://s.videogamer.com/meta/036a/1159b006-d50d-44f1-83b1-8b3098850866_472214e9-9e28-47f3-b442-6ba4bfe57a0d_Fallout76SteelDawn.jpg" alt="Fallout 76 releases Steel Dawn expansion a week early thanks to technical glitch" sizes="20vw"></picture><span class="content-item__article-type">NEWS</span></div><div class="content-item__details"><h3>Fallout 76 releases Steel Dawn expansion a week early thanks to technical glitch</h3></div></a></li></ul></section></div><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script><footer class="footer"><a href="https://twitter.com/intent/user?screen_name=VideoGamerCom" class="footer_link" rel="nofollow"><span class="rounded-icon social-icon--twitter"><svg role="presentation" class="icon icon-twitter" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-twitter"></use></svg></span>Follow us</a><a href="https://www.youtube.com/VideoGamerTV?sub_confirmation=1" class="footer_link" rel="nofollow"><span class="rounded-icon social-icon--youtube"><svg role="presentation" class="icon icon-youtube2" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-youtube2"></use></svg></span>Watch us</a><a href="https://www.facebook.com/VideoGamerCom" class="footer_link" rel="nofollow"><span class="rounded-icon social-icon--facebook"><svg role="presentation" class="icon icon-facebook" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-facebook"></use></svg></span>Like us</a><a href="/rss" class="footer_link" rel="nofollow"><span class="rounded-icon social-icon--rss"><svg role="presentation" class="icon icon-rss" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-rss"></use></svg></span>Subscribe</a><ul class="nav"><li><strong>&copy; 2018</strong></li><li><a href="/staff" title="Staff" rel="nofollow">Staff</a></li><li><a href="/contact-us" title="Contact" rel="nofollow">Contact</a></li><li><a href="/legal" title="Legal" rel="nofollow">Legal</a></li><li><a href="/privacy-policy" title="Privacy" rel="nofollow">Privacy Policy</a></li></ul><div class="footer_meta"><a href="http://www.reseronetwork.com" title="Resero Network" class="network_logo"><h4>Resero Network</h4></a><div class="network_sites js-hover"><span>Our Sites</span><ul><li><a href="http://pt.videogamer.com" title="VideoGamer Portugal">VideoGamer Portugal</a></li><li><a href="http://it.videogamer.com" title="VideoGamer Italy">VideoGamer Italy</a></li><li><a href="http://www.videogamer.gr" title="VideoGamer Greece">VideoGamer Greece</a></li><li><a href="https://www.xboxachievements.com" title="VideoGamer Greece">Xbox Achievements</a></li><li><a href="https://www.playstationtrophies.org" title="VideoGamer Greece">PlayStation Trophies</a></li></ul><svg role="presentation" class="icon icon-chevron-up" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-chevron-up"></use></svg></div></div></footer></div></div><div class="pswp" tabindex="-1" role="dialog" aria-hidden="true"><div class="pswp_advert"><div class="advert mpu-second" id="adunit-mpu-second" data-slot=""></div></div><div class="pswp__bg"></div><div class="pswp__scroll-wrap"><div class="pswp__container"><div class="pswp__item"></div><div class="pswp__item"></div><div class="pswp__item"></div></div><div class="pswp__ui pswp__ui--hidden"><div class="pswp__top-bar"><div class="pswp__counter invisible"></div><div class="pswp__customcounter"></div><button class="pswp__button pswp__button--close" title="Close (Esc)"><svg role="presentation" class="icon icon-cross" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-cross"></use></svg></button><button class="pswp__button pswp__button--fs" title="Toggle fullscreen"><svg role="presentation" class="icon icon-expand" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-expand"></use></svg></button><button class="pswp__button pswp__button--zoom" title="Zoom in/out"><svg role="presentation" class="icon icon-search" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-search"></use></svg></button><div class="pswp__preloader"><div class="pswp__preloader__icn"><div class="pswp__preloader__cut"><div class="pswp__preloader__donut"></div></div></div></div></div><div class="pswp__share-modal pswp__share-modal--hidden pswp__single-tap"><div class="pswp__share-tooltip"></div></div><button class="pswp__button pswp__button--arrow--left" title="Previous (arrow left)"><svg role="presentation" class="icon icon-chevron-left" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-chevron-left"></use></svg></button><button class="pswp__button pswp__button--arrow--right" title="Next (arrow right)"><svg role="presentation" class="icon icon-chevron-right" viewBox="0 0 32 32"><use xlink:href="/static/images/sprites.min.svg#icon-chevron-right"></use></svg></button><div class="pswp__caption"><div class="pswp__caption__center"></div></div></div></div></div>
<!-- Venatus Market v3 -->
<script>
    (function() {
        document.write('<div id="vmv3-ad-manager" style="display:none"></div>');
        document
            .getElementById("vmv3-ad-manager")
            .innerHTML = '<iframe id="vmv3-frm" src="javascript:\'<html><body></body></html>\'" width="0" height="0" data-mode="scan" data-site-id="58d923da46e0fb00017904ed"></iframe>';
        var loaderFrame = document.getElementById("vmv3-frm");
        var loaderFrameWindow = loaderFrame.contentWindow ? loaderFrame.contentWindow  : loaderFrame.contentDocument;
        loaderFrameWindow.document.open();
        loaderFrameWindow.document.write('<scr'+'ipt src="//hb.vntsm.com/v3/live/ad-manager.min.js" type="text/javascript" async>'+'</scr'+'ipt>');
        loaderFrameWindow.document.close();
    })();
</script>
<!-- / Venatus Market v3 -->
<!-- Venatus Market v3 - Videogamer - RICH MEDIA 1x1 -->
<div class="vm-placement" data-id="58d9240f46e0fb0001b87570" style="display: none"></div>
<!-- / Venatus Market v3 - Videogamer - RICH MEDIA 1x1 -->
<script defer="defer" src="/static/js/infrastructure.v3.js"></script><script defer="defer" src="/static/js/main.v3.js"></script><script>var pageConf = {base_url: 'www.videogamer.com',path: 'news/torchlight-3-gets-winter-themed-snow--steam-update-next-month',page_group: 'article',page_title_site: '- VideoGamer.com',debug: false, content: {published_date: '2020-11-27',author: {permalink: 'benborthwick',name: 'Ben Borthwick'}},};dataLayer = [pageConf];</script><script type="application/ld+json">[{"@context":"http://schema.org","@type":"WebSite","name":"VideoGamer.com","url":"https://www.videogamer.com","sameAs":["https://twitter.com/VideoGamerCom","https://www.facebook.com/VideoGamerCom","https://www.youtube.com/VideoGamerTV"]},{"@context":"http://schema.org","publisher":{"@type":"Organization","name":"VideoGamer.com","url":"https:\/\/www.videogamer.com","logo":{"@type":"ImageObject","url":"https://www.videogamer.com/static/images/videogamer-web-black-sml.png","width":532,"height":60}},"datePublished":"2020-11-27T13:51:40+00:00","dateModified":"2020-11-27T13:51:40+00:00","author":{"@type":"Person","name":"Ben Borthwick"},"creator":["Ben Borthwick"],"mainEntityOfPage":{"@type":"WebPage","@id":"https://www.videogamer.com/news/torchlight-3-gets-winter-themed-snow--steam-update-next-month"},"url":"https://www.videogamer.com/news/torchlight-3-gets-winter-themed-snow--steam-update-next-month","description":"Pretty cool stuff","@type":"NewsArticle","headline":"Torchlight 3 gets winter-themed &#039;Snow &amp; Steam&#039; update next month","articleSection":"News","image":{"@type":"ImageObject","contentUrl":"https://thumbs.videogamer.com/3o1qVxwGCUOJDVKSpfvFy58hbfA=/1920x1080/smart/https://s.videogamer.com/meta/d66b/4a855138-ab7e-4d68-b4ff-ffc595405123_Torchlight3WinterUpdate.jpg","url":"https://thumbs.videogamer.com/3o1qVxwGCUOJDVKSpfvFy58hbfA=/1920x1080/smart/https://s.videogamer.com/meta/d66b/4a855138-ab7e-4d68-b4ff-ffc595405123_Torchlight3WinterUpdate.jpg","width":1920,"height":1080},"thumbnailUrl":"https://thumbs.videogamer.com/3o1qVxwGCUOJDVKSpfvFy58hbfA=/1920x1080/smart/https://s.videogamer.com/meta/d66b/4a855138-ab7e-4d68-b4ff-ffc595405123_Torchlight3WinterUpdate.jpg","keywords":["article","news"]}]</script></body></html>